При запуске происходит попытка двойного создания ролей: level=CHANGE msg="Create role." role=ldap_login database=ldap2pg_test level=CHANGE msg="Create role." role=ldap_ddl database=ldap2pg_test level=CHANGE msg="Create role." role=ldap_login database=ldap2pg_test level=ERROR msg="Synchronisation error." err="ОШИБКА: роль \"ldap_login\" уже существует (SQLSTATE 42710)" level=CHANGE msg="Create role." role=ldap_ddl database=ldap2pg_test level=ERROR msg="Synchronisation error." err="ОШИБКА: роль \"ldap_ddl\" уже существует (SQLSTATE 42710)" Из-за чего сервис падает: level=ERROR msg="Some errors occurred. See above for more details." err="synchronization errors" count=2 level=ERROR msg="Run ldap2pg with --verbose to get more informations." ldap2pg.service: Main process exited, code=exited, status=1/FAILURE ldap2pg.service: Failed with result 'exit-code'. Failed to start Synchronize PostgreSQL roles and privileges from LDAP. Версия: ldap2pg-6.5.1-alt1.x86_64 В анонсе версии 6.6 https://blog.dalibo.com/2026/07/07/ldap2pg-6.6-en.html написано: "A deduplication bug caused missing roles to be created twice; this is now fixed." Скорее всего, это исправление как раз этой ошибки.
ldap2pg-6.6.0-alt1 -> sisyphus: Wed Jul 15 2026 Olesya Shuster <lesyafox@altlinux> 6.6.0-alt1 - New version 6.6.0 (closes: #59812, #59810)