Bug 6008 - syntax error for gcc3.4
: syntax error for gcc3.4
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libxmms-devel)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-02-02 20:44 by
Modified: 2006-02-17 19:25 (History)


Attachments
correct build for gcc.3.4 (170 bytes, patch)
2005-02-02 23:45, Ilya Mashkin
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-02-02 20:44:35
Не пересобирается пакет superkaramba-0.35-alt1
из-за (стандартной при переходе на gcc3.4?) ошибки в файле принадлежащем
libxmms-devel:

/usr/include/xmms/xmmsctrl.h:88: error: extra `;'
------- Comment #1 From 2005-02-02 20:59:05 -------
Если не трудно -- бросьте патчик, мож на выходных получится добраться...
------- Comment #2 From 2005-02-02 23:45:29 -------
Created an attachment (id=717) [details]
correct build for gcc.3.4

На сколько я понял нужно убрать только ";"
Патч прилагаю.
------- Comment #3 From 2005-03-27 21:57:43 -------
fixed in 1.2.10-alt4