php8.2-8.2.31-alt1 apache2-mod_php8.2-8.2.31-alt1 Стенд: Alt Server 10.4 x86_64 (office) Шаги воспроизведения: 1. Настроить БД: # apt-get install mariadb-server # systemctl enable --now mysqld # mysqladmin -u root password '1' # mysql -u root -p1 -Be "create user 'mediawiki'@'localhost' identified by 'mediawikipass'; # create database mediawiki default character set utf8 collate utf8_unicode_ci; grant all privileges on mediawiki.* to mediawiki@localhost; FLUSH PRIVILEGES;" 2. Настроить apache2 для запуска установки mediawiki: # apt-get install mediawiki mediawiki-apache2 mediawiki-mysql mediawiki-php8.3 apache2-mod_php8.3 # sed -i '/ServerName/s/ServerName.*/ServerName\tmediawiki.test.alt/' /etc/httpd2/conf/sites-available/mediawiki.conf # sed -i -e 's/memory_limit = 128M/memory_limit = 512M/g' /etc/php/8.3/apache2-mod_php/php.ini # a2enmod mod_php8.3; a2dismod mod_php8.2 # a2ensite mediawiki # a2dissite 000-default_https; a2dissite 000-default # systemctl restart httpd2 && sleep 5; systemctl status httpd2 3. Перейти в веб-интерфейс и начать установку (нажать на ссылку "set up the wiki") Результат: MediaWiki 1.40.1 installation Error starting session: session_start(): open(/var/lib/php/sessions/sess_c3ebbb3398f5b7006d7ed4c55027a09b, O_RDWR) failed: No such file or directory (2) Ожидаемый результат: запускается начало установки Причина: В apache2-mod_php8.2 путь сохранения сессий исправляется раньше, чем в php8.2, из-за этого получается следующее: # grep "session.save_path" /etc/php/8.2/cli/php.ini ;session.save_path = "/tmp" # grep "session.save_path" /etc/php/8.2/apache2-mod_php/php.ini session.save_path = "/var/lib/php/sessions" Mediawiki ищет директорию /var/lib/php/sessions, которую php8.2-libs не создает, т.к. исправление до него доберется только в 8.2.32-alt1 Полагаю, должно вылечиться обновлением php8.2-libs до 8.2.32-alt1 (либо обновлением php8.2 до 8.2.32-alt1, если php8.2-libs не может быть обновлен в одиночку) Сейчас чтобы продолжить установку директорию нужно создавать вручную и самостоятельно выдавать ей необходимые права. Теоретически, это может помешать установке любого приложения из веб-интерфейса, при этом возможность установки из cli сохраняется. В Р11 и Sisyphus не воспроизводится.
Результат проверки актуальности Состояние: MediaWiki не стартует сессию: нет /var/lib/php/sessions. В Branch p10 php8.2-8.2.31-alt1. Исправление в 8.2.32. В Sisyphus ошибка не воспроизводится; там php8.2-8.2.33-alt1. Рекомендация: оставить открытым в Branch p10.