Bug 6078 - Wrong jdbc version in postgresql-jdbc package
: Wrong jdbc version in postgresql-jdbc package
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/postgresql-jdbc)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-02-10 11:07 by
Modified: 2006-10-18 01:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-02-10 11:07:31
postgresql-jdbc-7.4.5-alt1.i586.rpm содержит (в 7.4.6 - аналогично)
pg73jdbc1.jar
pg73jdbc2.jar
pg73jdbc3.jar - которые с версией 7.4 Postgresql работают не корректно (есть
проблема с режимом AutoCommit, который с версии postgresql 7.3 не
поддерживается
серверной стороной).
Версии 
pg74.215.jdbc1.jar
pg74.215.jdbc2.jar
pg74.215.jdbc3.jar - скаченные с http://jdbc.postgresql.org/download.html
работают более корректно (проверено на OpenXchange)
Есть предложение заменить в пакете бинарники jdbc.
Steps to Reproduce:
1. Установить Postgresql (c jdbc)
2. Установить OpenXchange
3. Создавать/удалять Записи...
(более простой путь - написать на java небольшое приложение, использующее режим
AutoCommit... хотя в openXchange все уже написано)
Actual Results:  
При удалении записей из OpenXchange в программе заложена set AutoCommit=on/off
-
на что сервер ругается, и напоминает что этот режим не поддерживается.

Expected Results:  
С более новыми драйверами такой ошибки нет.
------- Comment #1 From 2005-04-08 04:47:14 -------
а попро
------- Comment #2 From 2005-04-08 04:49:53 -------
а попробуйте взять JDBC из postgresql8.0, если он нормально будет работать с
postgresql7, то мы наверное просто вынесем JDBC из postgresql.
------- Comment #3 From 2005-04-08 12:06:04 -------
1. jdbc в любом случае надо выносить из postgresql. это совершенно отдельный
проект.
2. есть backport postgresql7+slony1+new jdbc drivers. если оно надо, могу
положить в backports.
------- Comment #4 From 2005-04-08 13:05:28 -------
1. Это понятно. Просто надо решить сколько надо пакетов. Один или под каждую
версию.
2. Пока наверное не надо. С сизифом разберемся, потом и кинете. Спеки можно
кинуть мне личкой.
------- Comment #5 From 2005-04-15 13:55:09 -------
(In reply to comment #4)
> 1. Это понятно. Просто надо решить сколько надо пакетов. Один или под каждую
версию.

Тестировал работу open-xchange на posgresql 7.4 с jdbc3 версий 8.0 и 8.1.
Результат отрицательный. Похоже потребуется класть соотвествующую версию jdbc в
каждую сборку postgresql.
------- Comment #6 From 2005-04-15 13:58:04 -------
p.s. в соотвествии с java-policy самое лучшее место для jar'а - это
/usr/share/java/postgresqlXX/*.jar
------- Comment #7 From 2005-04-15 14:05:29 -------
В выходные я собираю postresql 8.0.2. В понедельник пойдет в сизиф. JDBC я от
него оторву, и залью отдельным пакетом. Поддерживать JDBC не собираюсь, ибо
Java
не использую вообще. Так что раздаю...

PS: Все программы можно собирать сразу с postgresql8. От 7.x пора понемногу
отказываться в сизифе. К ALM 3.0 все должно работать с 8.x.
------- Comment #8 From 2005-04-15 14:14:01 -------
(In reply to comment #7)

> Поддерживать JDBC не собираюсь, ибо Java
> не использую вообще. Так что раздаю...

хорошо, тогда заберу.
------- Comment #9 From 2005-06-18 08:19:04 -------
2 Mithraen:

JDBC crux@ отдельно собирает, так что оторви пожалуйста jdbc от постгреса и
закрой багу.
------- Comment #10 From 2005-06-18 17:50:48 -------
fixed (postgresql без jdbc ушёл в incoming)