Bug 6157 - Спорность удаления при dist-upgrade
: Спорность удаления при dist-upgrade
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/apt)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-02-23 14:23 by
Modified: 2010-10-30 13:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-02-23 14:23:43
Вот например сегодня. libflac в Сизифе обновили до so.7  
k3b остался требовать so.4, а остальные пакеты, требующие libflac, обновили.  
apt не долго думая предложил снести k3b.  
Весьма желательно не удалять при обновлении пакеты, т.е. удерживать от 
обновления те пакеты, установка которых привела бы к удалению других. 
Таким образом обновление libflac в системе произошло бы только после того, 
как все требующие его программы (k3b и т.д.) были бы пересобраны.
------- Comment #1 From 2007-06-24 19:34:14 -------
(In reply to comment #0)
> Весьма желательно не удалять при обновлении пакеты, т.е. удерживать от 
> обновления те пакеты, установка которых привела бы к удалению других. 
> Таким образом обновление libflac в системе произошло бы только после того, 
> как все требующие его программы (k3b и т.д.) были бы пересобраны.

+1. А ещё лучше сделать это в виде ручки - ВКЛ/ВЫКЛ. И включить по умолчанию.
Майнтайнеры/тестеры включать ручками удаление, а репутация Сизифа в среде
"чайников" будет лучше. :-)

P.S.: что, и помечтать нельзя? :-)
------- Comment #2 From 2010-10-30 13:18:00 -------
Это скорее про SharedLibsPolicy.