Bug 6216 - После сборки с поддержкой tls не запускается демон почты.
: После сборки с поддержкой tls не запускается демон почты.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/postfix)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-03-04 17:23 by
Modified: 2005-07-13 15:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-03-04 17:23:11
После персборки с поддержкой TLS не запускатеся демон, если в
/etc/postfix/master.cf выбран хотя бы один сервис с типом inet. сервисы с типом
fifo работают. Решение: собирать принудительно ещё и с поддержкой IPv6:

rpmbuild --rebuild --with tls --with ipv6 postfix-2.1.5-alt1.src.rpm
Steps to Reproduce:
1. rpmbuild --rebuild --with tls postfix-2.1.5-alt1.src.rpm
2.Установить все пакеты
3.В /etc/master.cf разрешить любой сервис с типом inet (например smtp)
4. service postfix restart
Actual Results:  
В /var/log/mail/all появляется:
Mar  4 14:42:28 server postfix/postfix-script: starting the Postfix mail system
Mar  4 14:42:28 server postfix/master[4574]: panic: myrealloc: requested length
0
Сервер не запускается.

Expected Results:  
Нормальная работа сервера.
------- Comment #1 From 2005-03-10 14:43:31 -------
В связи с выходом первой стабильной версии postfix-2.2 исправлять ipv6 в патче,
добавляющем поддержку tls в postfix-2.1, у меня нет никакого желания.
Проще включить ipv6 по умолчанию для postfix-tls (2.1.5-alt2).