Bug 6262 - Не могу использовать PostgreSQL в качестве хранилища данных
: Не могу использовать PostgreSQL в качестве хранилища данных
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/netams)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-03-14 03:11 by
Modified: 2005-09-07 12:27 (History)


Attachments
Данный патч содержит исправление ошибки (1.50 KB, patch)
2005-03-14 03:15, Sergei Epiphanov
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-03-14 03:11:29
При попытке внести в файл /etc/netams/netams.conf или через telnet строки

service storage 0
type postgres
...

Программа их игнорирует. Проблема в том, что на стадии сборки пакета
конфигуратор не находит libpq-fe.h из-за того, что он не оказывается в одном из
перечисленных каталогов. Для исправления нужно в configure.sh в список
каталогов
(строка 9: paths='...') добавить каталог /usr/include/pgsql и пересобрать.
Также
желательно перейти на netams версии 3.2.1 (сейчас появился текст:
14.03.2005 02:58:14.8784 ds_ulog:1 [INFO]: ULOG packet processing for
data-source:1 initialized
14.03.2005 02:58:14.9104 storage:0 [INFO]: postgres table 'oids' created
14.03.2005 02:58:14.9497 storage:0 [INFO]: ERROR:  duplicate key violates
unique
constraint "oids_pkey"
CONTEXT:  COPY oids, line 2: "215155,LANS"

14.03.2005 02:58:15.8834 main:0 [INFO]: postgres table 'events' created
)
Steps to Reproduce:
1. В файле /etc/netams/netams.conf прописать хранилище postgres
2. Запустить netams
3. В логах появляется информация, что неизвестный тип хранилища.
Actual Results:  
Не работает хранилище.

Expected Results:  
Нормальная работа
------- Comment #1 From 2005-03-14 03:15:19 -------
Created an attachment (id=770) [details]
Данный патч содержит исправление ошибки

Данный патч является объединением патча из netams-3.2.0 иисправления найденной
ошибки
------- Comment #2 From 2005-04-18 14:23:49 -------
Исправлено в новой версии 3.2.2