Bug 644 - Неверно собран пакет. Не запускается httpd-perl.
: Неверно собран пакет. Не запускается httpd-perl.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/apache-mod_perl)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-02-22 15:04 by
Modified: 2003-08-25 15:18 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-02-22 15:04:56
Пакет: apache-mod_perl-1.3.23rusPL30.11-alt3.i586.rpm
При попытке запуска httpd-perl выдает следующее:

[<a href="mailto:root@dvl" target="_new">root@dvl</a> apt]# service httpd-perl start
Starting httpd-perl: httpd-perl: Unable to exec Shared Core Executable Program `/usr/lib/apache-perl/libhttpd.ep\'

Вышеуказанный файл в каталоге /usr/lib/apache-perl отсутствует.
Он был обнаружен в каталоге /usr/lib/apache. После копирования его в требуемый каталог
httpd-perl продолжает ругаться:

[<a href="mailto:root@stone" target="_new">root@stone</a> apache-perl]# service httpd-perl start
Starting httpd-perl: httpd-perl: error while loading shared libraries: libhttpd.so: cannot open shared object file: No such file or directory

После добавления libhttpd.so в apache-perl получаем следующее:

[<a href="mailto:root@stone" target="_new">root@stone</a> apache]# service httpd-perl start
Starting httpd-perl: Syntax error on line 209 of /etc/httpd/conf/httpd-perl.conf:
Cannot add module via name \'mod_perl.c\': not in list of loaded modules

Файл mod_perl.so отсутствует в пакете. На этом попытки поднять httpd-perl
были прекращены. Т.е. пакет apache-mod_perl полностью неработоспособен.
---

---

------- Comment #1 From 2002-02-22 21:10:24 -------
Fixed in alt4. Please confirm.
------- Comment #2 From 2002-02-22 21:10:24 -------
Fixed in alt4. Please confirm.