Bug 6551 - authdaemond: PAM unable to dlopen(/lib/security/pam_limits.so)
: authdaemond: PAM unable to dlopen(/lib/security/pam_limits.so)
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/courier-authlib)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-04-16 01:53 by
Modified: 2005-07-31 06:21 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-04-16 01:53:32
courier-authlib-0.55-alt2
pam-0.75-alt28

# grep ^authmodulelist= /etc/courier-authlib/authdaemon.conf
authmodulelist="authpam"

Конфигурация PAM -- из коробки. При авторизации системного пользователя в
courier-imap в /var/log/messages появляются сообщения:

Apr 16 01:21:22 moria authdaemond: PAM unable to dlopen(/lib/security/pam_limits.so)
Apr 16 01:21:22 moria authdaemond: PAM [dlerror: /lib/security/pam_limits.so:
undefined symbol: pam_get_item]

При этом пользователь авторизуется и может нормально работать с ящиком. При
авторизации в login и sshd проблем с pam_limits.so не возникает.
------- Comment #1 From 2005-05-23 20:40:33 -------
Это ошибка сборки pam-0.75-alt28. Будет исправлена в новой версии Linux-PAM.

-------- Original Message --------
Subject: Re: [devel] Q: pam_limits.so: undefined symbol: pam_get_item -- BUG?
Date: Mon, 23 May 2005 19:48:47 +0400
From: Dmitry V. Levin
To: ALT Devel discussion list

On Tue, May 24, 2005 at 02:45:39AM +1100, Dmitry Lebkov wrote:
> Т.е. pam_limits.so не линкован с libpam.so? Или я чего-то недопонимаю?

Не слинкован.  Это баг.  Репортить нет смысла, поскольку версия Linux-PAM
слишком старая.  Вместе с новой версией будет исправлено.
-------- End of Original Message --------
------- Comment #2 From 2005-05-23 21:07:12 -------
Not courier-authlib bug.