Bug 6751 - после обновления Сизифа 20050428 не работает init-скрипт
: после обновления Сизифа 20050428 не работает init-скрипт
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/openswan)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-04-30 13:21 by
Modified: 2009-10-30 12:25 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-04-30 13:21:16
честно говоря, у меня ipsec не настроен и в сервисах остался случайно. 
Стартует он после запуска X-ов и что там происходит, было не видно.  
Очередной апгрейд привел к тому, что X-ы не старовали, и... В общем,  

service ipsec restart 

выдает кучу синтаксических ошибок, связанных с awk. Это частично: 

awk: cmd. line:89:      ^ syntax error 
awk: cmd. line:266:                     default[search] = rest 
awk: cmd. line:266:                     ^ syntax error 
awk: cmd. line:267:             else 
awk: cmd. line:267:             ^ syntax error 

Вроде бы раньше я это не замечал, хотя бывало, что X-ы не грузились.
------- Comment #1 From 2005-05-26 22:21:01 -------
Под каким ядром запускаете?

Под 2.6.х он не будет работать и скрипт будет выдавать ошибку.
------- Comment #2 From 2005-05-27 11:03:20 -------
Да, именно 2.6. Понятно. Закрываем, или пусть висит ? 
------- Comment #3 From 2005-05-27 13:05:27 -------
Пока пусть висит.

Я еще перепроверю работу под 2.4.х

Да и пусть висит как напоминание что давно пора доделать openswan2 :)
------- Comment #4 From 2006-02-14 13:52:25 -------
(In reply to comment #1)
> awk: cmd. line:89:      ^ syntax error 
> awk: cmd. line:266:                     default[search] = rest 
> awk: cmd. line:266:                     ^ syntax error 
> awk: cmd. line:267:             else 
> awk: cmd. line:267:             ^ syntax error 
>  
> Вроде бы раньше я это не замечал, хотя бывало, что X-ы не грузились.

Эта ошибка решается легко:
в файле /usr/lib/ipsec/_confread в скрипте awk надо заменить все слова default
на например default_ . Но ipsec все равно не работает. Проблемы глубже :(
------- Comment #5 From 2006-02-14 14:46:45 -------
> Но ipsec все равно не работает.

Не работает на ядре 2.4.x?
------- Comment #6 From 2008-12-05 14:10:40 -------
orphaned/openswan-1.0.9-alt1.src.rpm
------- Comment #8 From 2009-10-30 12:25:25 -------
orphaned, use strongswan