Bug 684 - wrong requires - lbnet-devel
: wrong requires - lbnet-devel
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/dsniff)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-03-04 13:13 by
Modified: 2009-05-10 09:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-03-04 13:13:51
dsniff при установке с помощью apt-get потянул libnet-devel. Странная
зависимость на -devel пакет.

dsniff-2.3-ipl5
libnet-devel-1.0.2a-ipl1mdk

---

---
------- Comment #1 From 2002-03-04 13:43:38 -------
Cannot reproduce this.
Please check package versions.
------- Comment #2 From 2002-03-04 13:43:38 -------
Cannot reproduce this.
Please check package versions.
------- Comment #3 From 2002-03-04 14:23:16 -------
$ apt-get remove libnet-devel
Обработка файловых зависимостей... Завершено
Чтение списков пакетов... Завершено         
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  libnet 
Следующие пакеты будут УДАЛЕНЫ:
  libnet-devel 
Следующие НОВЫЕ пакеты будут установлены:
  libnet 
0 пакетов будет обновлено, 1 будет добавлено новых, 1 будет удалено(заменено) и 0 не будет обновлено.

$ apt-get remove libnet
Обработка файловых зависимостей... Завершено
Чтение списков пакетов... Завершено         
Построение дерева зависимостей... Завершено
Следующие пакеты будут УДАЛЕНЫ:
  dsniff libnet libnids 
0 пакетов будет обновлено, 0 будет добавлено новых, 3 будет удалено(заменено) и 0 не будет обновлено.

$ apt-get install dsniff
Обработка файловых зависимостей... Завершено
Чтение списков пакетов... Завершено         
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  libnet-devel libnids 
Следующие НОВЫЕ пакеты будут установлены:
  dsniff libnet-devel libnids 
0 пакетов будет обновлено, 3 будет добавлено новых, 0 будет удалено(заменено) и 0 не будет обновлено.

$ rpm -q dsniff libnet-devel
dsniff-2.3-ipl5
libnet-devel-1.0.2a-ipl1mdk

PS apt-get в данном случае = \'sudo apt-get\'
------- Comment #4 From 2002-03-04 14:23:16 -------
$ apt-get remove libnet-devel
Обработка файловых зависимостей... Завершено
Чтение списков пакетов... Завершено         
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  libnet 
Следующие пакеты будут УДАЛЕНЫ:
  libnet-devel 
Следующие НОВЫЕ пакеты будут установлены:
  libnet 
0 пакетов будет обновлено, 1 будет добавлено новых, 1 будет удалено(заменено) и 0 не будет обновлено.

$ apt-get remove libnet
Обработка файловых зависимостей... Завершено
Чтение списков пакетов... Завершено         
Построение дерева зависимостей... Завершено
Следующие пакеты будут УДАЛЕНЫ:
  dsniff libnet libnids 
0 пакетов будет обновлено, 0 будет добавлено новых, 3 будет удалено(заменено) и 0 не будет обновлено.

$ apt-get install dsniff
Обработка файловых зависимостей... Завершено
Чтение списков пакетов... Завершено         
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  libnet-devel libnids 
Следующие НОВЫЕ пакеты будут установлены:
  dsniff libnet-devel libnids 
0 пакетов будет обновлено, 3 будет добавлено новых, 0 будет удалено(заменено) и 0 не будет обновлено.

$ rpm -q dsniff libnet-devel
dsniff-2.3-ipl5
libnet-devel-1.0.2a-ipl1mdk

PS apt-get в данном случае = \'sudo apt-get\'
------- Comment #5 From 2002-03-04 14:57:52 -------
Fixed in libnids-1.16-alt2
------- Comment #6 From 2002-03-04 14:57:52 -------
Fixed in libnids-1.16-alt2