Bug 6901 - гаснет монитор на FX5200
: гаснет монитор на FX5200
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/install2-x11-qt)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
: 7079
  Show dependency tree
 
Reported: 2005-05-19 11:44 by
Modified: 2006-09-10 21:25 (History)


Attachments
pciscan -v (4.31 KB, text/plain)
2005-06-13 20:13, Eugene V. Horohorin
no flags Details
lspci -vv (9.54 KB, text/plain)
2005-06-16 21:17, Eugene V. Horohorin
no flags Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-05-19 11:44:10
При попытке установки installer-2.9.9.6 на компьютер с nvidia fx5200, система 
стартует с диска, начинается процесс загружки инсталятора, и потом, после того 
как полоса добегает до конца монитор мигает (один или несколько раз, как при 
переключении режимов) и гаснет (подозрение на неподдерживаемый режим).
Пробовал выбирать разные режимы в меню инсталятора (1024, 1280, 800) -- 
результат тот же.

С тем же монитором, но на другой машине (видео TNT2) таких проблем замечено не 
было.

Монитор NEC FE700.
------- Comment #1 From 2005-06-08 19:25:51 -------
исправлено в installer-2.9.9.7.iso
------- Comment #2 From 2005-06-13 20:12:29 -------
2.9.9.7 -- не исправлено (проверено на двух разных ПК одинаковой конфигурации)! 
AMD64/Nvidia FX5200/nforce3-250 
------- Comment #3 From 2005-06-13 20:13:56 -------
Created an attachment (id=931) [details]
pciscan -v
------- Comment #4 From 2005-06-13 20:20:17 -------
Аналогично, при старте иксов монитор выключается. Если при загрузке выбрать 
разрешение 800x600 то монитор не выключается, но просто гаснет. Ctrl alt +(-) 
не работают, ctrl alt backspace работает, остается шелл (инсталлятор сам не 
виснет) 

 pciscan 
Recommended driver     Description 
------------------     ----------- 
unknown                nVidia Corporation nForce3 250Gb Host Bridge [Host 
bridge] 
unknown                nVidia Corporation nForce3 250Gb LPC Bridge [ISA bridge] 
unknown                nVidia Corporation nForce 250Gb PCI System Management 
[SMBus] 
ohci-hcd               nVidia Corporation CK8S USB Controller [OHCI USB 
Controller] 
ohci-hcd               nVidia Corporation CK8S USB Controller [OHCI USB 
Controller] 
ehci-hcd               nVidia Corporation nForce3 EHCI USB 2.0 Controller [EHCI 
USB Controller] 
unknown                nVidia Corporation CK8S Ethernet Controller [Bridge] 
snd-intel8x0           nVidia Corporation nForce3 250Gb AC'97 Audio Controller 
[Multimedia audio controller] 
amd74xx                nVidia Corporation CK8S Parallel ATA Controller (v2.5) 
[IDE interface storage controller] 
sata_nv                nVidia Corporation CK8S Serial ATA Controller (v2.5) 
[IDE interface storage controller] 
unknown                nVidia Corporation nForce3 250Gb AGP Host to PCI Bridge 
[PCI bridge Normal decode] 
unknown                nVidia Corporation nForce3 250Gb PCI-to-PCI Bridge [PCI 
bridge Normal decode] 
unknown                Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
HyperTransport Technology Configuration [Host bridge] 
unknown                Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Address Map [Host bridge] 
unknown                Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM 
Controller [Host bridge] 
unknown                Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] 
Miscellaneous Control [Host bridge] 
unknown                nVidia Corporation NV34 [GeForce FX 5200] [VGA 
compatible controller] 
8250_pci               3Com Corp, Modem Division (formerly US Robotics) 56K 
FaxModem Model 5610 [Serial controller 16550] 
------- Comment #5 From 2005-06-13 20:26:22 -------
(In reply to comment #4)  
> Аналогично, при старте иксов монитор выключается. Если при загрузке выбрать   
> разрешение 800x600 то монитор не выключается, но просто гаснет. Ctrl alt +(-)   
> не работают, ctrl alt backspace работает, остается шелл (инсталлятор сам не   
> виснет)   
>    
  
 это как раз на installer-2.9.9.7.iso 
------- Comment #6 From 2005-06-14 11:40:33 -------
Понятно. Мне нужно от вас результаты экспериментов с x11createconfig -f и
запуском xorg в установленной системе, но без драйвера nv и nvidia (должен быть
vesa по умолчанию).
------- Comment #7 From 2005-06-14 16:42:30 -------
и вообще - попробуйте погонять xorg с драйвером vesa. Возникает ощущение, что
nvidia плохо работает с vesa, что очень плохо ;-(
------- Comment #8 From 2005-06-14 18:51:49 -------
да, еще попробуйте с драйвером fbdev и vga
------- Comment #9 From 2005-06-14 21:00:21 -------
(In reply to comment #6)  
> Понятно. Мне нужно от вас результаты экспериментов с x11createconfig -f и  
> запуском xorg в установленной системе, но без драйвера nv и nvidia (должен  
быть  
> vesa по умолчанию).  
>   
  
Совершенно верно, работающая система с vesa ведет себя так-же (на инсталляторе  
x11createconfig дал именно vesa).   
  
С vga xorg отказался работать с 24 бита. а с 8 бит дал какое-то очень маленькое  
разрешение.  
 
С fbdev запустит не смог - нет /dev/fb0 , mknod сказал что надо миноры и 
мажоры.  
 
------- Comment #10 From 2005-06-14 21:02:22 -------
да, забыл, с nv все работает.  
------- Comment #11 From 2005-06-16 07:19:57 -------
Итого. Серия экспериментов показала:

Драйвер (глубина цвета):
fbdev(24) -- картинка смещена, цвета инвертированы
fbdev(16) -- иксы стартуют нормально
fbdev(8) -- картинка сжата по горизонтали на пол экрана, цвета инвертированы

vesa -- загрузиться иксам не удалось (то же самое что и на инсталяторе, гаснет
монитор)

vga (16/24) -- загрузиться не удалось (иксы выходят)
vga(8) -- каша в верхней части экрана, вся остальная площадь черный экран, кде
загрузилось (судя по звукам)

nv (8/16/24) -- загрузиться не удалось

x11createconfig -f -- создает vesa

P.$.: логи нужны?
------- Comment #12 From 2005-06-16 07:45:11 -------
PCI ID нужны, все четыре, наверное.
------- Comment #13 From 2005-06-16 13:21:56 -------
(In reply to comment #11)
> Итого. Серия экспериментов показала:
> 
> Драйвер (глубина цвета):
> fbdev(24) -- картинка смещена, цвета инвертированы
> fbdev(16) -- иксы стартуют нормально
> fbdev(8) -- картинка сжата по горизонтали на пол экрана, цвета инвертированы

ну что ж.. судя по всему fbdev - идеальный вариант.

> 
> vesa -- загрузиться иксам не удалось (то же самое что и на инсталяторе, гаснет
> монитор)

vesa отпадает ;-(

> 
> vga (16/24) -- загрузиться не удалось (иксы выходят)
> vga(8) -- каша в верхней части экрана, вся остальная площадь черный экран, кде
> загрузилось (судя по звукам)

мда.. vga отпадает.

> 
> nv (8/16/24) -- загрузиться не удалось

Интересно, а что ж в предыдущем посте сказали что с nv все работает ?
Так работает или нет ?

> 
> x11createconfig -f -- создает vesa
> 
> P.$.: логи нужны?


разве что шреку. Шрек ?
------- Comment #14 From 2005-06-16 13:23:03 -------
(In reply to comment #9)
> (In reply to comment #6)  
> > Понятно. Мне нужно от вас результаты экспериментов с x11createconfig -f и  
> > запуском xorg в установленной системе, но без драйвера nv и nvidia (должен  
> быть  
> > vesa по умолчанию).  
> >   
>   
>  
> С fbdev запустит не смог - нет /dev/fb0 , mknod сказал что надо миноры и 
> мажоры.  

Нужно загрузить систему с vga=0x317 (например)

------- Comment #15 From 2005-06-16 13:23:56 -------
Я думаю что стоит в следущем installer добавить nv на вторую стадию и
посмотреть
на результаты. 

Иначе остается только fbdev, что собственно крайне грустно ;-(
------- Comment #16 From 2005-06-16 14:25:00 -------
Евгений, логи от nv киньте в личку 
------- Comment #17 From 2005-06-16 16:41:06 -------
лучше прямо сюда.
------- Comment #18 From 2005-06-16 21:11:36 -------
Простите меня дуру грешную...
Тестировал работу с nv без установленного пакета xorg-x11-drv-nv
Сейчас поставил, проверил -- все работает (во всех режимах).
vesa же работает (судя по звукам и работе диска), однако уводит монитор в
глубокую спячку
------- Comment #19 From 2005-06-16 21:17:58 -------
Created an attachment (id=943) [details]
lspci -vv

как и просили, lspci -vv
------- Comment #20 From 2005-06-16 21:22:15 -------
есть еще не изданные логи попыток загрузиться с vesa и pciscan -v --
интересует?
или вопрос на этом (nv работает!!!!) закроем?
------- Comment #21 From 2005-06-18 23:30:43 -------
(In reply to comment #14) 
 
> > С fbdev запустит не смог - нет /dev/fb0 , mknod сказал что надо миноры и  
> > мажоры.   
>  
> Нужно загрузить систему с vga=0x317 (например) 
>  
>  
 
При этом автоматически будет создано нужное устройство? (не использую fb, из-за 
известной проблемы nvidia) 
 
 
Собственно nv в инсталлере-то вроде как не проверен (потому-что даже vi вроде 
как нет) 
 
------- Comment #22 From 2005-06-23 20:11:01 -------
можно так -- после вывала в консоль (только что на 2.9.9.9/gf2):

subst 's/nvidia/nv/' /tmp/xconfig
install2-x11-qt
------- Comment #23 From 2005-06-23 20:49:19 -------
(из недоповешенной новой баги про то же самое)

в системе при этом _нет_ nvidia.ko, соотв. он не загружен.

также в конфиге присутствует Load "glx", что не совсем понятно для инсталера
(как минимум память), хотя проблем не создаёт (setglx выставил линки в
*null*.so).

или уже настраиваться на коммерческий драйвер, или на что-то из перечисленных
здесь, или в зависимости от поколения/конкретно известных проблем.  плюс imco
стоит учитывать ситуации, когда только nvidia будет уметь распоследний чип :-(
------- Comment #24 From 2005-06-24 03:00:55 -------
(In reply to comment #23)
> в системе при этом _нет_ nvidia.ko, соотв. он не загружен.

и init выбрасывает в баш, дальше я делал следующее:
subst 's,nvidia,nv,' /tmp/xconfig
install2-x11-qt
затем exit, после выхода из bash init продолжает действовать по плану. 

проблем не замечено.

> или уже настраиваться на коммерческий драйвер, или на что-то из перечисленных

ну либо kernel-modules-nvidia включить в образ install2, либо тупо объехать в
init таким subst, либо научить x11createconfig доп.ключам
------- Comment #25 From 2005-06-24 03:02:54 -------
пробовалось на geforce2mx и riva tnt2
------- Comment #26 From 2005-06-24 09:41:57 -------
Что, в конфиге получается nvidia ?

Очень странно, сейчас пойду чинить. Должен вообще то быть nv.
------- Comment #27 From 2005-06-24 11:27:08 -------
2Zerg:
нужно оторвать зависимость у ядерного модуля nvidia на nvidia_glx, иначе
nvidia_glx вытаскивается в installer
------- Comment #28 From 2005-06-24 11:28:02 -------
2zerg: или не делать симлинк с nvidia_drv на nvidiadrvnull (а что это за бня
такая ?)
------- Comment #29 From 2005-07-05 10:32:13 -------
теперь уже точно исправлено в 2.9.10.iso
------- Comment #30 From 2005-07-05 12:58:46 -------
Насколько понимаю, разве в 2.9.11.

На 2.9.10 install2 отрабатывает на nv (замечательно), install3 стартует тоже на
nv, а вот alterator-x11 пытается настроить nvidia и взрывается, ибо:

[root@localhost root]# l /etc/X11/lib_nvidia/
total 4
drwxr-xr-x  20 root root 4096 Jul  5 14:45 ../
drwxr-xr-x   2 root root  147 Jul  5 14:21 ./
lrwxrwxrwx   1 root root   26 Jul  5 14:21 nvidia_drv.so -> apt-get install
NVIDIA_GLX
lrwxrwxrwx   1 root root   26 Jul  5 14:21 nvidia_drv.o -> apt-get install
NVIDIA_GLX
lrwxrwxrwx   1 root root   39 Jul  5 14:21 libnvidia-tls.so.1 ->
../../../usr/X11R6/lib/libnvidianull.so
lrwxrwxrwx   1 root root   39 Jul  5 14:21 libXvMCNVIDIA_dynamic.so.1 ->
../../../usr/X11R6/lib/libnvidianull.so
lrwxrwxrwx   1 root root   39 Jul  5 14:21 libNVIDIAXvMC.so ->
../../../usr/X11R6/lib/libnvidianull.so
lrwxrwxrwx   1 root root   39 Jul  5 14:21 libGLcore.so.1 ->
../../../usr/X11R6/lib/libnvidianull.so

2 zerg: прикол в офисе заценили (sr@ продлил его до -> rm -rf / :)
------- Comment #31 From 2005-07-05 13:03:06 -------
Эта ошибка не имеет отношения к alterator-x11. Для него была своя ;-)
------- Comment #32 From 2005-07-05 13:12:00 -------
да, сорри, у меня про эти две _разные_ баги полное дежавю %(
------- Comment #33 From 2005-07-06 23:01:17 -------
2.9.11+GF2: OK

genix, проверяй на FX :)
------- Comment #34 From 2005-07-08 22:49:06 -------
(In reply to comment #33) 
> 2.9.11+GF2: OK 
>  
> genix, проверяй на FX :) 
 
Работает (2.9.11).  
 
Система установилась, все шаги (установки) отработали корректно, установленная 
система работоспособна.  
 
Известная проблема с фреймбуфером (при nvidia в иксах мусор в консоли) 
относится сюда или это общий вопрос инсталлятора? 
 
------- Comment #35 From 2005-07-11 14:05:23 -------
(In reply to comment #34)
> Известная проблема с фреймбуфером (при nvidia в иксах мусор в консоли) 
> относится сюда или это общий вопрос инсталлятора? 
Третье -- проблема драйвера => форс-мажор... см. #3083