Bug 7008 - Должен ли быть пакет postgresql8.0-devel?
: Должен ли быть пакет postgresql8.0-devel?
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/postgresql8.0-devel)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-06-05 19:41 by
Modified: 2008-03-23 01:57 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-06-05 19:41:23
Мне кажется, раз есть libpq4, и есть к нему libpq4-devel, то заголовочные 
файлы в нём и должны быть, а то он пустой. 
Отказ от пакета postresql8.0-devel привёл бы всё к стандартной схеме 
libXXX, libXXX-devel.
------- Comment #1 From 2005-06-05 20:26:00 -------
Похоже на правду. Надо будет подумать.
------- Comment #2 From 2005-06-05 20:48:39 -------
Ну не знаю... postgresql-devel таскает с собой не только заголовки от libpq, но
и половину сборочного дерева... так что я против.
------- Comment #3 From 2005-06-05 23:16:47 -------
Если речь идёт о 
/usr/lib/pgsql/pgxs 
то он занимает 56К 
"Половина сборочного дерева" - это Makefile, я так понимаю. Они нужны, 
например, для сборки модулей к PostgreSQL из contribs. 
Ещё раз: в чём смысл и логика существования 2 пакетов, в одном из которых 
сейчас только 1 симлинк, а другой назван не в соответствии с полиси на 
упаковку библиотек и devel-файлов к ним? 
 
 
------- Comment #4 From 2006-10-18 01:17:31 -------
Что с этим делать будем?
Я сторонник скорее минимальных сборочных зависимостей, чем больших метапакетов
тянущих за собой все.
------- Comment #5 From 2006-10-18 11:07:06 -------
Возможно я не очень понял, что за половина сборочного дерева.
Впрочем, моё дело заметить, а решать - ответственному за пакет.
------- Comment #6 From 2007-05-03 15:08:37 -------
Также прошу сделать devel пакет, чтоб хоть файлы заголовков были. И это же
относится к 8.1.
------- Comment #7 From 2008-03-23 01:57:58 -------
В общем резюме "шлите патчи"