Bug 7045 - hwdatabase: broken ALSA driver, need OSS support
: hwdatabase: broken ALSA driver, need OSS support
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/hwdatabase)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-06-09 04:20 by
Modified: 2005-06-30 10:01 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-06-09 04:20:26
this ICH2 onboard audio (i815) couldn't be made to work (ppracer, bb) with:

kernel-modules-alsa-std26-up-1.0.9a-alt2.10
libalsa-1.0.8-alt2
alsa-utils-1.0.8-alt1.1

but started to work after installing kernel-modules-oss-std26-up (NB: not in
kernel-complete), removing snd_* and modprobing i810_audio:

unknown                Intel Corporation 82801BA/BAM AC'97 Audio [Multimedia
audio controller]
                       8086:2445:8086:4532  drivers: snd-intel8x0  class:004:01:00
                       slot: 0000:00:1f.5  hwid: 3FE695BDC8E416F3

dmesg hints it's 48KHz problem:

intel8x0_measure_ac97_clock: measured 49640 usecs
intel8x0: clocking to 48000
[...]
Intel 810 + AC97 Audio, version 1.01, 19:41:24 May 15 2005
ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 9 (level, low) -> IRQ 9
PCI: Setting latency timer of device 0000:00:1f.5 to 64
i810: Intel ICH2 found at IO 0xef00 and 0xe800, MEM 0x0000 and 0x0000, IRQ 9
i810_audio: Audio Controller supports 6 channels.
i810_audio: Defaulting to base 2 channel mode.
i810_audio: Resetting connection 0
ac97_codec: AC97 Audio codec, id: ADS96 (Analog Devices AD1885)
i810_audio: AC'97 codec 0 Unable to map surround DAC's (or DAC's not present),
total channels = 2

I'm afraid it's the same saga as usual...
------- Comment #1 From 2005-06-09 11:31:36 -------
(In reply to comment #0)
> this ICH2 onboard audio (i815) couldn't be made to work (ppracer, bb)

А с чем-нибудь попроще (aplay -vv)?  alsamixer полностью прошерстили (там с
Headphones могут быть фокусы)?

Возможно, надо покрутить параметр модуля ac97_quirk - там в списке кучка
записей, но такого subsystem id пока нет.

> but started to work after installing kernel-modules-oss-std26-up (NB: not in
> kernel-complete)

Вообще kernel-modules-oss, похоже, пригоден только для настройки руками (при его
установке hotplug начинает вести себя случайным образом).

> dmesg hints it's 48KHz problem:

Не похоже - AD1885 вроде бы поддерживает VRA.

> intel8x0_measure_ac97_clock: measured 49640 usecs
> intel8x0: clocking to 48000

Это он всегда пишет - видимо, есть заметное количество плат с кривой частотой. 
В данном случае всё нормально.
------- Comment #2 From 2005-06-09 11:59:30 -------
Headphones подёргал (размутил, поднял, вот mute назад при поднятом разве не
делал). Всё остальное -- поднято, разумное -- подёргано.

ac97_quirk -- попробую успеть посмотреть.

re oss vs hotplug -- не знаю, что дешевле -- починить alsa или его по этой
части... тут ещё #7034 починить надо, а там -- воткнул модуль и Всё Работает
(TM) => обидно, однако...
------- Comment #3 From 2005-06-27 20:16:40 -------
не смогу добавить oss, просьба повесить отдельную ошибку на alsa.
------- Comment #4 From 2005-06-29 22:13:28 -------
Чесгря, не вижу особого смысла -- все драйверы ALSA Сергею всё равно не
выровнять, мы с тобой это хорошо понимаем... поэтому читать багу стоило "надо
поддерживать и OSS".

Предлагать помочь чинить hwdatabase не буду, завален.
------- Comment #5 From 2005-06-30 10:01:00 -------
ну когда развалишься, то WELCOME ;-)