Bug 7110 - Module loop don't load automatically
: Module loop don't load automatically
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/udev)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-06-16 13:40 by
Modified: 2005-07-13 20:15 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-06-16 13:40:00
При попытке монтировать iso образ автоматически на загружается модуль loop  
sudo mount  -o loop ~/iso/Master-2.4-install-cd.iso ~/mnt/cdrom 
mount: could not find any device /dev/loop# 

Если загрузить loop принудительно монтирование проходит нормально. 

sudo modprobe loop 
[iscander@gfl41 dev]$ sudo mount  -o loop ~/iso/Master-2.4-install-cd.iso 
~/mnt/cdrom 

[iscander@gfl41 dev]$ ls ~/mnt/cdrom 
ALTLinux     dosutils  License.txt-CP1251  README.components  RPM-GPG-KEY 
autorun.inf  images    License.txt-KOI8-R  README.images      rr_moved 
docs         isolinux  misc                README.security    VERSION 

[iscander@gfl41 dev]$uname -a 
Linux gfl41 2.6.11-std26-up-alt10 #1 Sun May 15 19:40:10 MSD 2005 i686 unknown 
unknown GNU/Linux 
[iscander@gfl41 dev]$ rpm -qa | grep udev 
udev-0.50-alt5 

Steps to Reproduce:
1.mount  -o loop ~/iso/Master-2.4-install-cd.iso ~/mnt/cdrom 
2. 
3. 
Actual Results:  
mount: could not find any device /dev/loop# 

Expected Results:  
Монтирование loopback устройства с автоматической загрузкой модуля loop
------- Comment #1 From 2005-06-16 13:41:50 -------
Алексей, я правильно понимаю что нужно патч на ядро ?
------- Comment #2 From 2005-06-16 13:49:31 -------
Модуль loop не может правильно работать с полностью динамическим созданием
устройств через udev - необходимо создавать /dev/loop* статически (хотя бы
/dev/loop0, остальные устройства (в соответствии с параметром max_loop) будут
созданы при загрузке модуля loop).
------- Comment #3 From 2005-07-13 20:15:08 -------
поставьте пакет udev_static-complete