Bug 7270 - # apt-get install kdevelop без # apt-get install python-base python-modules не устанавливалься, хотя должен был всё поставить сам.
: # apt-get install kdevelop без # apt-get install python-base python-modules н...
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/python-modules)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-07-02 18:00 by
Modified: 2005-07-03 12:51 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-07-02 18:00:27
># apt-get install "python2.4(string)" "python2.4(repr)"
>> Чтение списков пакетов... Завершено
>> Построение дерева зависимостей... Завершено
>> Выбрано python-modules для 'python2.4(string)'
>> Выбрано python-modules для 'python2.4(repr)'
>> Некоторые пакеты установить невозможно. Это может означать, что Вы
>> потребовали невозможного, либо пользуетесь нестабильным репозиторием.
>> Часть необходимых пакетов либо ещё не создана, либо была удалена
>> из каталога 'Входящие'.
>> Эти сведения могут помочь найти выход из ситуации:
>>
>> Следующие пакеты имеют неудовлетворенные зависимости:
>>   python-modules: Требует: python-base (= 2.4.1-alt3) но пакет не будет
>> установлен
>>                   Требует: python2.4(UserDict)
>>                   Требует: python2.4(__future__)
>>                   Требует: python2.4(bisect)
>>                   Требует: python2.4(copy_reg)
>>                   Требует: python2.4(dis)
>>                   Требует: python2.4(email)
>>                   Требует: python2.4(inspect)
>>                   Требует: python2.4(linecache)
>>                   Требует: python2.4(mimetools)
>>                   Требует: python2.4(mimetypes)
>>                   Требует: python2.4(new)
>>                   Требует: python2.4(os)
>>                   Требует: python2.4(posixpath)
>>                   Требует: python2.4(readline)
>>                   Требует: python2.4(rfc822)
>>                   Требует: python2.4(stat)
>>                   Требует: python2.4(token)
>>                   Требует: python2.4(tokenize)
>>                   Требует: python2.4(types)
>>                   Требует: python2.4(warnings)
>> E: Извините, `битые' пакеты



А так:

# apt-get install python-base python-modules

всё отлично устанавливается.

 Но раньше
# apt-get install kdevelop
 без

 # apt-get install python-base python-modules
 не устанавливалься, хотя должен был всё поставить сам.
 Я считаю, что это бага.
 Не так ли?
 Куда её вешать?


Точно не знаю, но судя по тому, что

# apt-get install python-modules

не проходило, то бага в python-modules?

Led.
Подробности: http://lists.altlinux.ru/pipermail/sisyphus/2005-July/063334.html
------- Comment #1 From 2005-07-02 20:32:33 -------
Я попытался это воспроизвести и считаю, что ко мне это отношения 
не имеет, перевесте, плз, на kdevelop-common:   

%apt-get install kdevelop  
Reading Package Lists... Done  
Building Dependency Tree... Done  
Some packages could not be installed. This may mean that you have  
requested an impossible situation or if you are using the unstable  
distribution that some required packages have not yet been created  
or been moved out of Incoming.  

Since you only requested a single operation it is extremely likely that  
the package is simply not installable and a bug report against  
that package should be filed.  
The following information may help to resolve the situation:  

The following packages have unmet dependencies:  
  kdevelop: Depends: kdevelop-common (= 2:3.2.1-alt3) but it is not going to be 
installed  
E: Broken packages  
%apt-get install kdevelop kdevelop-common  
Reading Package Lists... Done  
Building Dependency Tree... Done  
The following extra packages will be installed:  
  altlinux-menus autoconf-common autoconf_2.5 automake-common automake_1.9  
cpp3.4 ctags  
  design-graphics-sisyphus docbook-dtds doxygen e2fsprogs enscript esound  
gcc-c++-common  
  gcc-common gcc3.4 gcc3.4-c++ gettext gettext-tools glibc glibc-devel  
glibc-kernheaders iconv  
  kde-common kde-settings kdelibs kernel-headers-common libOpenSP libSDL  
libSDL-devel libalsa  
  libart_lgpl libarts libarts-qtmcop libaudiofile libcups libgcc3.4 libgcrypt  
libgpg-error libjack  
  libjasper libjbig libjpeg-devel libkrb5 libmad libmdnsresponder libnetpbm  
libogg libqt3  
  libqt3-sqlite libssl libssl-devel libstdc++3.4 libstdc++3.4-devel libtiff  
libtool-common  
  libtool_1.5 libvorbis libxorgconfig libxslt m4 make netpbm openjade patch  
python-base  
  python-modules python-modules-bsddb python-modules-compiler  
python-modules-curses  
  python-modules-email python-modules-encodings python-modules-hotshot  
python-modules-logging  
  python-modules-xml python-strict sgml-common sgml-tools sharutils sqlite  
xml-utils  
  xorg-x11-bitmaps xorg-x11-devel xorg-x11-font-utils xorg-x11-libs  
xorg-x11-locales  
  xorg-x11-mesagl xorg-x11-xauth zlib-devel  
The following packages will be upgraded  
7 upgraded, 84 newly installed, 0 removed and 57 not upgraded.  
Need to get 75,4MB/80,3MB of archives.  
After unpacking 182MB of additional disk space will be used.  
Do you want to continue? [Y/n]  sudo apt-get install kdevelop kdevelop-common  
Reading Package Lists... Done  
Building Dependency Tree... Done  
The following extra packages will be installed:  
  altlinux-menus autoconf-common autoconf_2.5 automake-common automake_1.9  
cpp3.4 ctags  
  design-graphics-sisyphus docbook-dtds doxygen e2fsprogs enscript esound  
gcc-c++-common  
  gcc-common gcc3.4 gcc3.4-c++ gettext gettext-tools glibc glibc-devel  
glibc-kernheaders iconv  
  kde-common kde-settings kdelibs kernel-headers-common libOpenSP libSDL  
libSDL-devel libalsa  
  libart_lgpl libarts libarts-qtmcop libaudiofile libcups libgcc3.4 libgcrypt  
libgpg-error libjack  
  libjasper libjbig libjpeg-devel libkrb5 libmad libmdnsresponder libnetpbm  
libogg libqt3  
  libqt3-sqlite libssl libssl-devel libstdc++3.4 libstdc++3.4-devel libtiff  
libtool-common  
  libtool_1.5 libvorbis libxorgconfig libxslt m4 make netpbm openjade patch  
python-base  
  python-modules python-modules-bsddb python-modules-compiler  
python-modules-curses  
  python-modules-email python-modules-encodings python-modules-hotshot  
python-modules-logging  
  python-modules-xml python-strict sgml-common sgml-tools sharutils sqlite  
xml-utils  
  xorg-x11-bitmaps xorg-x11-devel xorg-x11-font-utils xorg-x11-libs  
xorg-x11-locales  
  xorg-x11-mesagl xorg-x11-xauth zlib-devel  
The following packages will be upgraded  

------- Comment #2 From 2005-07-02 22:26:46 -------
Можно локализовать проблему до предела.
Скомандуйте следующее:

# apt-get remove python-base python-modules

<skip>

# apt-get install python-modules

Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Некоторые пакеты установить невозможно. Это может означать, что Вы
потребовали невозможного, либо пользуетесь нестабильным репозиторием.
Часть необходимых пакетов либо ещё не создана, либо была удалена
из каталога 'Входящие'.

Так как для выполнения Вашего запроса достаточно одной операции, то
скорее всего этот пакет просто невозможно установить. Сообщите, пожалуйста,
об этом как о найденной ошибке в пакете.
Эти сведения могут помочь найти выход из ситуации:

Следующие пакеты имеют неудовлетворенные зависимости:
  python-modules: Требует: python-base (= 2.4.1-alt3) но пакет не будет установлен
                  Требует: python2.4(UserDict)
                  Требует: python2.4(__future__)
                  Требует: python2.4(bisect)
                  Требует: python2.4(copy_reg)
                  Требует: python2.4(dis)
                  Требует: python2.4(email)
                  Требует: python2.4(inspect)
                  Требует: python2.4(linecache)
                  Требует: python2.4(mimetools)
                  Требует: python2.4(mimetypes)
                  Требует: python2.4(new)
                  Требует: python2.4(os)
                  Требует: python2.4(posixpath)
                  Требует: python2.4(readline)
                  Требует: python2.4(rfc822)
                  Требует: python2.4(stat)
                  Требует: python2.4(token)
                  Требует: python2.4(tokenize)
                  Требует: python2.4(types)
                  Требует: python2.4(warnings)
E: Извините, `битые' пакеты

-----------------------
И всё же похоже, что всё дело всё-таки в python-modules.
Согласны?
------- Comment #3 From 2005-07-03 12:51:26 -------
Andrey Orlov пишет:

>Не воспроизвелось..... Все нормально поставилось
>Может у вас и впрям какая то кривизна с репозиторием 
>или какие старые версии пакетов застряли? Там были
>некоторые проблемы с зависимостями..
>
Вы оказались совершенно правы. Действительно были старые пакеты.

>Попробуйте так:
>
>apt-get remove $(rpm -qa --qf "%{NAME}\n" "python*")
>
>(аккуратно, может вынести пол системы)
>
Снесло:
MPlayer-fonts kdevelop kdevelop-common kdevelop-for-qt openoffice.org
openoffice.org-ru
  python-base python-modules python-modules-bsddb python-modules-compiler
python-modules-curses
  python-modules-email python-modules-encodings python-modules-hotshot
python-modules-logging
  python-modules-xml python-relaxed python2.3-base python2.3-modules
python2.3-modules-bsddb
  python2.3-modules-compiler python2.3-modules-curses python2.3-modules-email
  python2.3-modules-encodings python2.3-modules-hotshot python2.3-modules-logging
  python2.3-modules-xml python2.3-relaxed xchat

т.е. помимо:
     python*
ещё и :

MPlayer-fonts kdevelop kdevelop-common kdevelop-for-qt openoffice.org
openoffice.org-ru xchat

>
>apt-get install что там у вас? python-modules
>
Сделал:
[root@homehost beet]# apt-get remove $(rpm -qa --qf "%{NAME}\n" "python*")
[root@homehost beet]# apt-get install python-modules
[root@homehost beet]# apt-get install xchat kdevelop MPlayer-fonts kdevelop
kdevelop-common kdevelop-for-qt openoffice.org-ru

Было:
# echo $(rpm -qa --qf "%{NAME}\n" "python*")
python-modules python-modules-xml python-modules-encodings
python2.3-modules-hotshot python2.3-base python-base python2.3-modules-email
python2.3-modules-bsddb python-modules-hotshot python2.3-modules-curses
python2.3-modules-xml python2.3-modules-encodings python2.3-modules-compiler
python2.3-relaxed python-modules-compiler python-modules-bsddb
python-modules-logging python2.3-modules-logging python2.3-modules
python-modules-email python-modules-curses python-relaxed

Стало:
# echo $(rpm -qa --qf "%{NAME}\n" "python*")
python-modules-encodings python-modules-email python-modules-logging
python-modules-compiler python-modules-xml python-strict python-modules
python-modules-hotshot python-base python-modules-bsddb python-modules-curses

Теперь всё хорошо. Спасибо.