Bug 7374 - Пустой пакет, в частности нет библиотеки /usr/lib/tcl/libpgtcl.so.2.
: Пустой пакет, в частности нет библиотеки /usr/lib/tcl/libpgtcl.so.2.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libpgtcl2)
: unstable
: all Linux
: P3 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-07-15 11:16 by
Modified: 2005-11-01 14:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-07-15 11:16:50
Нет библиотеки /usr/lib/tcl/libpgtcl.so.2. Из-за неё не запускается PgAccess:

$ pgaccess


Error: Shared library file: '/usr/lib/tcl/libpgtcl.so.2' does not exist.
 Check this file, or check PGLIB variable (in pgaccessrc)

$ rpm -qil libpgtcl2
Name        : libpgtcl2                    Relocations: (not relocateable)
Version     : 8.0.3                             Vendor: ALT Linux Team
Release     : alt2                          Build Date: Втр 28 Июн 2005
18:25:34
Install date: Птн 15 Июл 2005 10:55:56      Build Host:
bee5.hasher.altlinux.org
Group       : Базы данных                   Source RPM:
postgresql8.0-8.0.3-alt2.src.rpm
Size        : 0                                License: BSD
Packager    : PostgreSQL Maintainers Team <pgsql@packages.altlinux.org>
URL         : http://www.postgresql.org/
Summary     : Tcl/Tk library and front-end for PostgreSQL
Description :
The postgresql-tcl package contains the pg-enhanced pgtclsh and the library
to enable Tcl/Tk scripts to communicate with the PostgreSQL database backend.
postinstall program: /sbin/ldconfig
postuninstall program: /sbin/postun_ldconfig
(не содержит файлов)
$
------- Comment #1 From 2005-07-15 11:47:26 -------
Вот кусок из SPEC:

...
%files -n %libpgtcl_name
%files -f server.lang server
...

Необходимо добавить как минимум:
%_libdir/tcl/libpgtcl.so.2
------- Comment #2 From 2005-07-15 12:11:57 -------
А этой библиотеки даже в исходниках нет... Зачем же тогда пакет libpgtcl2?
------- Comment #3 From 2005-08-14 18:32:10 -------
*** Bug 7577 has been marked as a duplicate of this bug. ***
------- Comment #4 From 2005-11-01 14:31:28 -------
Этот пакет выделился в отдельный проект. Я удалил его из спека.