Bug 7515 - Не устанавливается
: Не устанавливается
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-complete-std26-up)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-07-29 21:20 by
Modified: 2008-08-02 04:09 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-07-29 21:20:13
Для тестирования сборки инсталлера необходимо, чтобы kernel-complete-std26-up
был устанавливаемый.

В случае, если какие-то модули в настоящий момент не достаточно хорошо
мантейнятся, предлагаю повесить на них block-баги, при этом убрав их из
requires
kernel-complete-*

У меня есть мнение, что семантика apt-get install kernel-complete-... должна
быть не "поставить _все_ модули ядра", а "поставить все _существующие_ в
репозитории модули для этого язра".

В противном случае, в настоящий момент, kernel-complete просто не имеет смысла.
------- Comment #1 From 2005-07-29 21:56:09 -------
Даже не совсем все существующие - например, пакет kernel-modules-oss при этом
ставится не должен (поскольку содержит устаревшие модули, конфликтующие по
записям в modules.pcimap с kernel-modules-alsa, и без дополнительной настройки
фактически ломает звук).

Впрочем, в настоящее время пакеты kernel-complete-* бесполезны для чего-либо,
кроме инсталятора - обновить ядро, запросив этот пакет, нельзя.
------- Comment #2 From 2005-07-29 22:10:05 -------
Понимаю. А может это стоит заодно кинуть в README.ALT в документации?
------- Comment #3 From 2005-12-10 22:24:25 -------
Fixed in kernel-complete-std26-up-2.6.14-alt2.