Bug 7670 - Не работает VMWare 5
: Не работает VMWare 5
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/kernel-image-wks26-up)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-08-14 01:05 by
Modified: 2005-09-07 00:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-08-14 01:05:18
При старте:
---
Starting VMware services:
   Virtual machine monitor  [ DONE ]
   Virtual ethernet            [ DONE ]
   Bridged networking on /dev/vmnet0  [FAILED]
   Host-only networking on /dev/vmnet1 (background)  [ DONE ]
   Host-only networking on /dev/vmnet8 (background)  [ DONE ]
   NAT service on /dev/vmnet8   [ DONE ]
------
dmesg:
------
/dev/vmnet: open called by PID 11963 (vmnet-bridge)
/dev/vmnet: hub 0 does not exist, allocating memory.
/dev/vmnet: port on hub 0 successfully opened
bridge-eth0: enabling the bridge
Unable to handle kernel NULL pointer dereference at virtual address 00000069
 printing eip:
b0234f49
*pde = 00000000
Oops: 0000 [#1]
PREEMPT
Modules linked in: vmnet parport_pc vmmon nfs lockd sunrpc wacom subfs thermal 
processor fan button ide_cd cdrom via_ircc irda crc_ccitt emu10k1_gp gameport 
via_agp snd_mpu401 snd_mpu401_uart sd_mod usb_storage scsi_mod pcspkr 
uhci_hcd ehci_hcd usbcore snd_emu10k1 snd_rawmidi snd_ac97_codec snd_pcm_oss 
snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device 
snd_mixer_oss snd_pcm snd_timer snd_page_alloc snd_util_mem snd_hwdep snd 
soundcore bt878 tvaudio bttv tuner video_buf firmware_class i2c_algo_bit 
v4l2_common btcx_risc tveeprom i2c_core videodev eepro100 mii reiser4 
zlib_deflate zlib_inflate ext2 mbcache xfs exportfs dm_mod ppdev parport 
evdev tsdev capability commoncap psmouse nvidia agpgart rtc reiserfs ide_disk 
ide_generic via82cxxx ide_core
CPU:    0
EIP:    0060:[<b0234f49>]    Tainted: P      VLI
EFLAGS: 00210246   (2.6.12-wks26-up-alt4)
EIP is at sk_alloc+0x9/0x140
eax: c641000e   ebx: c641e600   ecx: 0000000b   edx: cf1b8000
esi: c641e60c   edi: 00000000   ebp: 00000001   esp: b051be0c
ds: 007b   es: 007b   ss: 0068
Process vmnet-bridge (pid: 11963, threadinfo=b051a000 task=cfbdc060)
Stack: c641e600 c641e600 c641e60c 00000000 c641e60c d102073d 00000010 00000020
       00000001 00000000 c641e600 cf1b8005 c641e611 d102091f c641e600 d1021418
       c641e60c cf1b8000 c641e600 00000000 c641e600 b023bb17 c641e600 00000001
Call Trace:
 [<d102073d>] VNetBridgeUp+0xbd/0x1e0 [vmnet]
 [<d102091f>] VNetBridgeNotify+0x5f/0x130 [vmnet]
 [<b023bb17>] register_netdevice_notifier+0x57/0x60
 [<d1020005>] VNetBridge_Create+0x75/0x240 [vmnet]
 [<d101d5f2>] VNetFileOpIoctl+0x212/0x470 [vmnet]
 [<b01553af>] handle_mm_fault+0x12f/0x170
 [<b0113ff7>] do_page_fault+0x1a7/0x5c8
 [<b0176006>] do_ioctl+0x46/0x70
 [<b0176193>] vfs_ioctl+0x53/0x1c0
 [<b017635d>] sys_ioctl+0x5d/0x70
 [<b0103009>] syscall_call+0x7/0xb
Code: 00 00 c7 44 24 0c 00 00 00 00 e9 89 fc ff ff ba ea ff ff ff c7 44 24 04 
04 00 00 00 e9 51 fc ff ff 90 55 57 56 53 53 8b 6c 24 20 <8b> 75 68 85 f6 0f 
84 fc 00 00 00 8b 4c 24 1c 51 56 e8 d1 94 f1
 <6>note: vmnet-bridge[11963] exited with preempt_count 1
scheduling while atomic: vmnet-bridge/0x10000001/11963
 [<b0299038>] schedule+0x598/0x640
 [<b029992a>] cond_resched+0x2a/0x50
 [<b0153967>] unmap_vmas+0x247/0x260
 [<b0157f54>] exit_mmap+0x64/0x140
 [<b0117c63>] mmput+0x23/0x90
 [<b011c523>] do_exit+0xe3/0x430
 [<b0234f49>] sk_alloc+0x9/0x140
 [<b0104820>] die+0x160/0x170
 [<b01141e6>] do_page_fault+0x396/0x5c8
 [<b0114206>] do_page_fault+0x3b6/0x5c8
 [<b0115641>] __activate_task+0x11/0x20
 [<b01164aa>] __wake_up_common+0x2a/0x60
 [<b0298d5e>] schedule+0x2be/0x640
 [<b0298dd2>] schedule+0x332/0x640
 [<b0299122>] preempt_schedule+0x42/0x60
 [<b011a891>] release_console_sem+0xd1/0xf0
 [<b0113e50>] do_page_fault+0x0/0x5c8
 [<b010409f>] error_code+0x4f/0x60
 [<b0234f49>] sk_alloc+0x9/0x140
 [<d102073d>] VNetBridgeUp+0xbd/0x1e0 [vmnet]
 [<d102091f>] VNetBridgeNotify+0x5f/0x130 [vmnet]
 [<b023bb17>] register_netdevice_notifier+0x57/0x60
 [<d1020005>] VNetBridge_Create+0x75/0x240 [vmnet]
 [<d101d5f2>] VNetFileOpIoctl+0x212/0x470 [vmnet]
 [<b01553af>] handle_mm_fault+0x12f/0x170
 [<b0113ff7>] do_page_fault+0x1a7/0x5c8
 [<b0176006>] do_ioctl+0x46/0x70
 [<b0176193>] vfs_ioctl+0x53/0x1c0
 [<b017635d>] sys_ioctl+0x5d/0x70
 [<b0103009>] syscall_call+0x7/0xb
scheduling while atomic: vmnet-bridge/0x00000001/11963
 [<b0299038>] schedule+0x598/0x640
 [<b0217082>] generic_unplug_device+0x22/0x40
 [<b02999ee>] io_schedule+0xe/0x20
 [<b01459c9>] sync_page+0x39/0x50
 [<b0299bb0>] __wait_on_bit+0x40/0x70
 [<b0145990>] sync_page+0x0/0x50
 [<b014608d>] wait_on_page_bit+0x9d/0xb0
 [<b012e310>] wake_bit_function+0x0/0x40
 [<b012e310>] wake_bit_function+0x0/0x40
 [<d11e6e25>] jload_gfp+0x1b5/0x1d0 [reiser4]
 [<d11e82c3>] zload_ra+0x23/0x30 [reiser4]
 [<d11e82dc>] zload+0xc/0x10 [reiser4]
 [<d11e9c96>] lock_carry_node_tail+0x16/0x20 [reiser4]
 [<d11ea53d>] find_left_neighbor+0xed/0x150 [reiser4]
 [<d11eb203>] make_space_by_shift_left+0x13/0xc0 [reiser4]
 [<d11eb54e>] make_space_for_flow_insertion+0x2e/0x80 [reiser4]
 [<d11eb68e>] carry_insert_flow+0xee/0x1a0 [reiser4]
 [<d11e6f66>] jrelse_tail+0x26/0x50 [reiser4]
 [<d11e9531>] carry_on_level+0x31/0xb0 [reiser4]
 [<d11e942a>] carry+0x7a/0x150 [reiser4]
 [<d11ed6b0>] insert_flow+0xb0/0xe0 [reiser4]
 [<d1219775>] write_tail+0xd5/0x1c0 [reiser4]
 [<d122e28c>] write_page_by_tail+0x10c/0x150 [reiser4]
 [<d122e500>] extent2tail+0x1b0/0x330 [reiser4]
 [<d122ce7e>] release_unix_file+0x6e/0xd0 [reiser4]
 [<d12044c4>] reiser4_release+0x64/0x70 [reiser4]
 [<b0164344>] __fput+0x104/0x140
 [<b015601a>] remove_vm_struct+0x5a/0x90
 [<b0157ffa>] exit_mmap+0x10a/0x140
 [<b0117c63>] mmput+0x23/0x90
 [<b011c523>] do_exit+0xe3/0x430
 [<b0234f49>] sk_alloc+0x9/0x140
 [<b0104820>] die+0x160/0x170
 [<b01141e6>] do_page_fault+0x396/0x5c8
 [<b0114206>] do_page_fault+0x3b6/0x5c8
 [<b0115641>] __activate_task+0x11/0x20
 [<b01164aa>] __wake_up_common+0x2a/0x60
 [<b0298d5e>] schedule+0x2be/0x640
 [<b0298dd2>] schedule+0x332/0x640
 [<b0299122>] preempt_schedule+0x42/0x60
 [<b011a891>] release_console_sem+0xd1/0xf0
 [<b0113e50>] do_page_fault+0x0/0x5c8
 [<b010409f>] error_code+0x4f/0x60
 [<b0234f49>] sk_alloc+0x9/0x140
 [<d102073d>] VNetBridgeUp+0xbd/0x1e0 [vmnet]
 [<d102091f>] VNetBridgeNotify+0x5f/0x130 [vmnet]
 [<b023bb17>] register_netdevice_notifier+0x57/0x60
 [<d1020005>] VNetBridge_Create+0x75/0x240 [vmnet]
 [<d101d5f2>] VNetFileOpIoctl+0x212/0x470 [vmnet]
 [<b01553af>] handle_mm_fault+0x12f/0x170
 [<b0113ff7>] do_page_fault+0x1a7/0x5c8
 [<b0176006>] do_ioctl+0x46/0x70
 [<b0176193>] vfs_ioctl+0x53/0x1c0
 [<b017635d>] sys_ioctl+0x5d/0x70
 [<b0103009>] syscall_call+0x7/0xb
/dev/vmnet: open called by PID 11989 (vmnet-natd)
/dev/vmnet: hub 8 does not exist, allocating memory.
/dev/vmnet: port on hub 8 successfully opened
/dev/vmnet: open called by PID 12006 (vmnet-netifup)
/dev/vmnet: port on hub 8 successfully opened
/dev/vmnet: open called by PID 12005 (vmnet-netifup)
/dev/vmnet: hub 1 does not exist, allocating memory.
/dev/vmnet: port on hub 1 successfully opened
------
------- Comment #1 From 2005-08-14 08:45:07 -------
Попробуйте с последним update с ftp.cvut.cz/vmware.
------- Comment #2 From 2005-08-14 19:33:30 -------
У меня с vmware-any-any-update93 работает.

kernel-image-wks26-up-2.6.12-alt1
------- Comment #3 From 2005-08-14 21:29:19 -------
Проблема была в оригинальной (старой) версии vmnet.
С vmware-any-any-update93 (взятому с ftp.cvut.cz/vmware) работает.
Большое спасибо Andrey Rahmatullin и Eugene Vlasov.
------- Comment #4 From 2005-08-16 11:22:52 -------
*** Bug 7683 has been marked as a duplicate of this bug. ***