Bug 7754 - Ряд странностей, которых не понимаю
: Ряд странностей, которых не понимаю
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/g-wrap)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-08-26 00:27 by
Modified: 2008-02-15 23:52 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-08-26 00:27:17
1. По моему недосмотру g-wrap раньше собирался с  
libffi-devel  
это не нужно, потому что пока собирается тот libffi, который встроен внутрь  
g-wrap (это плохо, и я бы переключился на внешний, но все программы (guile)  
завязались именно на /usr/lib/libffi.so.4, и системный /usr/lib/libffi.so.3 их  
не устраивает - пересобрать надо?)  
К тому же libg-wrap начинает предоставлять libffi (незаметно для окружающих).  
А что будет, когда выйдёт пакет libffi4.0 вместо libffi3.4?  

2. Осторожно, сборочные зависимости на   
g-wrap libg-wrap-devel   
выставляются при buildreq, но не нужны конечно и вредны (перестают ставиться  
srfi-35, srfi-36 - не знаю правда что это :))  

3. Непонятно, зачем (и насколько это корректно) g-wrap тянёт себе glib-devel  
(первой версии). Лучше бы такой зависимости не было, мне кажется это чревато  
проблемами (древняя библиотека в современном окружении).  

Я не знаю, насколько замечания корректны, просто записал чтобы не забылось.
------- Comment #1 From 2005-08-26 00:27:54 -------
на мантейнера 
------- Comment #2 From 2005-09-04 18:18:39 -------
(In reply to comment #0) 
> 1. По моему недосмотру g-wrap раньше собирался с   
> libffi-devel   
[skip] 
> А что будет, когда выйдёт пакет libffi4.0 вместо libffi3.4?   
 
Надо узнать в каком состоянии сейчас libffi4.0 и совместно перейти на внешний, 
если он уже есть у кого-нибудь в сборке, буду смотреть, иначе подожду. 
 
> 2. Осторожно, сборочные зависимости на    
> g-wrap libg-wrap-devel    
> выставляются при buildreq, но не нужны конечно и вредны (перестают ставиться   
> srfi-35, srfi-36 - не знаю правда что это :))   
 
Хм... а, как тогда формализовать явную необходимость g-wrap для сборки, если он 
указан в configure.in? 
 
> 3. Непонятно, зачем (и насколько это корректно) g-wrap тянёт себе glib-devel   
> (первой версии). Лучше бы такой зависимости не было, мне кажется это чревато   
> проблемами (древняя библиотека в современном окружении).   
 
Да, это верно. 
 
> Я не знаю, насколько замечания корректны, просто записал чтобы не забылось. 
 
Спасибо :) 
 
Кстати, а почему я не могу менять статус моего бага? 
 
------- Comment #3 From 2005-09-04 20:09:51 -------
(In reply to comment #2) 
> > 2. Осторожно, сборочные зависимости на     
> > g-wrap libg-wrap-devel     
   
> Хм... а, как тогда формализовать явную необходимость g-wrap для сборки, если 
он  
> указан в configure.in?  
g-wrap нужен для сборки g-wrap? 
 
> > Я не знаю, насколько замечания корректны, просто записал чтобы не 
забылось.  
>   
> Спасибо :)  
:) 
 
> Кстати, а почему я не могу менять статус моего бага?  
Вот уж не знаю, это к владельцу bugzilla :)  
А что, все пункты серые? 
 
------- Comment #4 From 2005-09-05 02:45:09 -------
(In reply to comment #3)    
> (In reply to comment #2)     
> > > 2. Осторожно, сборочные зависимости на         
> > > g-wrap libg-wrap-devel         
>        
> > Хм... а, как тогда формализовать явную необходимость g-wrap для сборки,    
если     
> он      
> > указан в configure.in?      
> g-wrap нужен для сборки g-wrap?     
    
Так для g-wrap, g-wrap явно и не указан, я не понял в каком смысле ты указывал    
на сборочную зависимость на g-wrap. У меня так:    
rpm -qp --requires /var/ftp/Sisyphus/SRPMS.classic/g-wrap-1.9.6-alt1.src.rpm    
gcc-c++    
glib-devel # << Вот это есть!    
guile16-devel    
indent    
libffi-devel    
libstdc++-devel    
pkgconfig    
rpmlib(CompressedFileNames) <= 3.0.4-1    
Я подумал что, это про пользователей g-wrap, хотя в этом случае бага должна  
быть на них.  
    
> > Кстати, а почему я не могу менять статус моего бага?      
> Вот уж не знаю, это к владельцу bugzilla :)      
> А что, все пункты серые?     
    
Нет, предложен выбор только из одного checkbox'а:    
 none  Leave as NEW   
 
------- Comment #5 From 2005-09-05 03:23:15 -------
(In reply to comment #4) 
> Так для g-wrap, g-wrap явно и не указан, я не понял в каком смысле ты 
указывал     
> на сборочную зависимость на g-wrap. У меня так:     
> rpm -qp --requires /var/ftp/Sisyphus/SRPMS.classic/g-wrap-1.9.6-alt1.src.rpm     
Я в спеке в строчке BuildRequires увидел. Если нету - замечательно. 
Главное чтобы при buildreq потом не проявилось. 
 
> Нет, предложен выбор только из одного checkbox'а:     
>  none  Leave as NEW    
... 
А, понял. Ты зарегистрировался с @altlinux.org, а багой владеет @altlinux.ru. 
Мантейнер должен под .org логиниться, по крайней мере все так делают. 
 
 
------- Comment #6 From 2005-09-14 18:06:13 -------
(In reply to comment #5)   
> (In reply to comment #4)    
> > Так для g-wrap, g-wrap явно и не указан, я не понял в каком смысле ты    
> указывал        
> > на сборочную зависимость на g-wrap. У меня так:        
> > rpm -qp   
--requires /var/ftp/Sisyphus/SRPMS.classic/g-wrap-1.9.6-alt1.src.rpm        
> Я в спеке в строчке BuildRequires увидел. Если нету - замечательно.    
> Главное чтобы при buildreq потом не проявилось.    
   
Да, такая строка есть, но она закомментирована.  
С конфликтом библиотек будем разбираться, как только появится сборка libffi4.0. 
 
------- Comment #7 From 2006-10-18 01:33:24 -------
Всё учтено и исправлено в
* Wed Oct 18 2006 Vitaly Lipatov <lav@altlinux.ru> 1.9.6-alt3
------- Comment #8 From 2008-02-15 23:42:46 -------
re
------- Comment #9 From 2008-02-15 23:45:08 -------
Раз учтено и исправлено, то FIXED.