Bug 7930 - Please build it with cairo.gtk support
: Please build it with cairo.gtk support
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/python-module-pycairo)
: unstable
: all Linux
: P2 enhancement
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-09-12 11:11 by
Modified: 2005-11-22 11:58 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-09-12 11:11:21
"subj" =)
------- Comment #1 From 2005-09-12 19:50:58 -------
Автоответ: 
пожалуйста, перепишите Ваше письмо, не используя слова 
Subj, сабж, субж, опция. 
 
Ваше письмо получено, но в текущем виде может быть не обработано адресатом. 
 
------- Comment #2 From 2005-09-12 20:02:16 -------
Она вообще-то не хотела собираться с pygtk >= 2.7, но я её уговорил. 
fixed in python-module-pycairo-1.0.0-alt2.src.rpm 
------- Comment #3 From 2005-09-15 18:08:15 -------
[dfo@dfo dfo]$ rpm -q python-module-pycairo
python-module-pycairo-1.0.0-alt2
[dfo@dfo dfo]$ echo -e 'import gtk\nimport cairo\nimport cairo.gtk' | python
Traceback (most recent call last):
  File "<stdin>", line 3, in ?
ImportError: No module named gtk
------- Comment #4 From 2005-09-16 02:39:50 -------
Судя по коду, в версии pygtk 2.7 произошли изменения, с которыми эта 
библиотека ещё не готова собираться. 
Предложения и патчи приветствуются, пакеты раздаются. 
------- Comment #5 From 2005-09-19 15:49:45 -------
(In reply to comment #4)
> Судя по коду, в версии pygtk 2.7 произошли изменения, с которыми эта 
> библиотека ещё не готова собираться. 
> Предложения и патчи приветствуются, пакеты раздаются. 

судя по INSTALL от pycairo:
However, if PyGTK >= 2.7.0 is detected then cairo.gtk is not built since pycairo
is now supported directly by PyGTK.

значит перевесим на python-module-pygtk
------- Comment #6 From 2005-11-22 11:58:15 -------
Всё исправлено в  
python-module-pycairo-1.0.2-alt1.src.rpm