Bug 8008 - dbus-daemon не работает в режиме --session на текущем сизифе
: dbus-daemon не работает в режиме --session на текущем сизифе
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/dbus)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-09-19 11:35 by
Modified: 2005-10-12 12:32 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-09-19 11:35:23
dbus-daemon не работает в режиме --session на текущем сизифе

Steps to Reproduce:
1.$ sudo service messagebus start
2.$ dbus-monitor
Failed to open connection to session message bus: Unable to determine the
address of the message bus
3.$ dbus-monitor --system
signal sender=org.freedesktop.DBus -> dest=:1.1 interface=org.freedesktop.DBus;
member=NameAcquired
 string ":1.1"
тут видно что следить за системной шиной таки можно
4. запускаем пользовательский режим
$ dbus-launch
DBUS_SESSION_BUS_ADDRESS='unix:abstract=/var/run/dbus/users/dbus-G5BbAPDLPo,guid=00672e4398e05fc2b6488fb99f951700'
DBUS_SESSION_BUS_PID=2691
проверяем 
$ ps aux | grep dbus
113       6387  0.0  0.0   2032  1012 ?        Ss   Sep16   0:00
/usr/bin/dbus-daemon --system
vkhilko   2691  0.0  0.0   1908   664 ?        Ss   10:21   0:00 dbus-daemon
--fork --print-pid 8 --print-address 6 --session
демон запущен и работает, но

$ dbus-monitor
Failed to open connection to session message bus: Unable to determine the
address of the message bus
$ dbus-monitor --session
Failed to open connection to session message bus: Unable to determine the
address of the message bus

$ rpm -qa | grep dbus
dbus-tools-gui-0.50-alt1
python-module-dbus-0.50-alt1
libdbus-glib-devel-0.50-alt1
libdbus-devel-0.50-alt1
libdbus-qt-0.50-alt1
dbus-tools-0.50-alt1
libdbus-0.50-alt1
dbus-0.50-alt1
libdbus-glib-0.50-alt1

рекомендации с вики выполнялись, но это позволило запустить лишь системный
режим
работы
------- Comment #1 From 2005-09-19 14:44:36 -------
*** Bug 8010 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2005-09-19 14:44:41 -------
*** Bug 8009 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2005-09-19 14:45:32 -------
неправда. все работает. надо только читать документацию:
[rider@vrider i686]$ dbus-launch 
DBUS_SESSION_BUS_ADDRESS='unix:abstract=/var/run/dbus/users/dbus-zWekM8UtPy,guid=66962e43444e9dfe59a03508e684ae00'
DBUS_SESSION_BUS_PID=27503
[rider@vrider i686]$ export
DBUS_SESSION_BUS_ADDRESS='unix:abstract=/var/run/dbus/users/dbus-zWekM8UtPy,guid=66962e43444e9dfe59a03508e684ae00'
[rider@vrider i686]$ export DBUS_SESSION_BUS_PID=27503
[rider@vrider i686]$ dbus-monitor 
signal sender=org.freedesktop.DBus -> dest=:1.0 interface=org.freedesktop.DBus;
member=NameAcquired
 string ":1.0"
method call sender=:1.0 -> dest=org.freedesktop.DBus
interface=org.freedesktop.DBus; member=AddMatch
 string "type='method_call'"
method call sender=:1.0 -> dest=org.freedesktop.DBus
interface=org.freedesktop.DBus; member=AddMatch
 string "type='method_return'"
method call sender=:1.0 -> dest=org.freedesktop.DBus
interface=org.freedesktop.DBus; member=AddMatch
 string "type='error'"

[rider@vrider i686]$ dbus-monitor --session
signal sender=org.freedesktop.DBus -> dest=:1.1 interface=org.freedesktop.DBus;
member=NameAcquired
 string ":1.1"
method call sender=:1.1 -> dest=org.freedesktop.DBus
interface=org.freedesktop.DBus; member=AddMatch
 string "type='method_call'"
method call sender=:1.1 -> dest=org.freedesktop.DBus
interface=org.freedesktop.DBus; member=AddMatch
 string "type='method_return'"
method call sender=:1.1 -> dest=org.freedesktop.DBus
interface=org.freedesktop.DBus; member=AddMatch
 string "type='error'"