Bug 8020 - [3.1] we should configure chips still supported by latest nvidia!
: [3.1] we should configure chips still supported by latest nvidia!
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/hwdatabase)
: unstable
: all Linux
: P2 blocker
Assigned To:
:
:
:
:
: 7079 9199
  Show dependency tree
 
Reported: 2005-09-20 21:05 by
Modified: 2008-02-21 21:15 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-09-20 21:05:08
3.0-rc7 не смог завести иксы на gf2 -- хорошо бы хоть nv сконфигурировать,
половиной вопросов в community@/support@ будет меньше, да и прикручивать glx
уже
веселей.

плюс -- если мы соберём и будем поддерживать в updates или рядом kernel-modules
и nvidia_glx где-то 4496 или ближайший с разумными затратами на собрать/завести
-- примешь на диск?
------- Comment #1 From 2005-09-21 21:41:10 -------
From: "Pavel N. Solovyov"

> >   А в rc6 выходит никак?
> заменить nvidia на nv в /tmp/xconfig

  Сделал проще. На время установки воткнул старенькую ATI Rageon,
система поднялась со свистом. Потом поставил драйвера Nvidia, заменил в
xorg.conf ATI на Nvidia, выключил, воткнул обратно GF2 MX400 (нет худа
без добра - смазал кулер, который еле крутился) и всё ОК.

--- ой.
------- Comment #2 From 2005-09-22 12:17:42 -------
Всё ещё забавнее, я даже и не подумал проверить наличие при запуске
install2-x11-qt загруженного nvidia.ko.  Так вот нет его в /lib/modules.

А с nv и vesa не взлетаем (MX440) -- мёрзнем соответственно с X-курсором
посреди
экрана и в странном режиме с редким длинным горизонтальным "снегом".

Перевесь на что-то или почини так, поскольку GF2/GF4 MX в 7676, оказывается,
всё
же поддерживаются:

Appendix A. Supported NVIDIA Graphics Chips
[...]
    GeForce2 MX/MX 400                 0x0110
    GeForce4 MX 440                    0x0171
[...]

Below are the legacy GPUs that are no longer supported in the
unified driver.  These GPUs will continue to be maintained
through the special legacy NVIDIA GPU driver releases.

    RIVA TNT                           0x0020
    RIVA TNT2/TNT2 Pro                 0x0028
    RIVA TNT2 Ultra                    0x0029
    Vanta/Vanta LT                     0x002C
    RIVA TNT2 Model 64/Model 64 Pro    0x002D
    Aladdin TNT2                       0x00A0
    GeForce 256                        0x0100
    GeForce DDR                        0x0101
    Quadro                             0x0103
    GeForce2 GTS/GeForce2 Pro          0x0150
    GeForce2 Ti                        0x0151
    GeForce2 Ultra                     0x0152
    Quadro2 Pro                        0x0153
------- Comment #3 From 2005-09-22 12:18:37 -------
PS: это в rc7
------- Comment #4 From 2005-10-05 15:13:42 -------
Исправлено в rc8
------- Comment #5 From 2005-10-05 23:46:06 -------
мож выплесни предварительную xdelta, проверю до rc8?
------- Comment #6 From 2006-02-21 19:36:02 -------
Для 3.1 бум делать разделение старые/новые нвидии или старые на
самообслуживание/nv?
------- Comment #7 From 2006-02-21 19:42:37 -------
голосую за разделение nvidia_старые/новые и nv для любителей (опция?).
------- Comment #8 From 2006-03-09 14:26:16 -------
голосуйте. Только предварительно попросить переименовать драйвера компанию
nvidia.
------- Comment #9 From 2006-03-10 10:24:13 -------
Ну это понятно, что не прокатит.  То же решение, которое для таких случаев
может
подойти -- конфликтует с kernel-complete.  Тут непонятно -- это был хак для
того, чтобы всё точно встало (в т.ч. из-за того, что связку kudzu/urpmi немного
время разломало), или предполагалось потихоньку возвращаться к практике
установки только нужных драйверов?

Если второе -- можно попробовать для начала обточить и поддерживать 4496 или
около того в Sisyphus, иначе особого смысла нет.
------- Comment #10 From 2006-03-10 10:28:49 -------
(In reply to comment #9)

> Если второе -- можно попробовать для начала обточить и поддерживать 4496 или
> около того в Sisyphus, иначе особого смысла нет.

даже если в дистриубтиве будет 4496 рядышком в unsupported/contrib/misc и
инструкция по их установке это уже лучше чем ничего.

у меня с ходу собрать не получилось, пожет вывалить куда-нить логи сборки?

------- Comment #11 From 2006-03-10 10:29:14 -------
P.$.: а есть еще nv_lite -- никто не смотрел что это?
------- Comment #12 From 2006-03-10 12:43:39 -------
Сливал, толком не смотрел, но он явно не занимался хаком имён по бинарям за
ненадобностью.  По постановке задачи.

http://alphagate.hopto.org/nv_lite/
------- Comment #13 From 2006-03-13 09:55:03 -------
В общем могу сказать одно:

nVidia сама себе злобная буратино. Какого-то варианта, предполагающего
нормальную поддержку этих драйверов в Sisyphus - я не вижу.

Например: что вы будете делать, когда эти старые драйвера перестанут работать со
следующей версией ядер/xorg ?

Вывод: пинайте nVidia. пускай исходники например откроют.
------- Comment #14 From 2006-03-13 09:56:49 -------
(In reply to comment #13)

> Например: что вы будете делать, когда эти старые драйвера перестанут работать со
> следующей версией ядер/xorg ?

ну мы пока о конкретном дистрибутиве речь ведем, и если есть возможность то
почему бы не воспользоваться ей? ;)
------- Comment #15 From 2008-02-21 21:14:47 -------
re
------- Comment #16 From 2008-02-21 21:15:07 -------
was fixed by mighty zerg@ ;-)