Bug 8163 - Missing dependency on libgtkhtml3
: Missing dependency on libgtkhtml3
Status: CLOSED DUPLICATE of bug 7644
: Sisyphus
(All bugs in Sisyphus/libgtk-sharp2)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-10-08 15:52 by
Modified: 2007-09-22 11:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-10-08 15:52:34
Documentation window in monodevelop requires libgtkhtml3, and if it's missing, 
monodevelop crashes when trying to view documentation:

Unhandled Exception: System.DllNotFoundException: libgtkhtml-3.6.so.18
in (wrapper managed-to-native) Gtk.HTML:gtk_html_new ()
in <0x00060> Gtk.HTML:.ctor ()
in <0x00020> MonoDevelop.Gui.HelpViewer:.ctor ()
in <0x001d0> MonoDevelop.Gui.Pads.HelpTree:ShowDocs (System.String text, 
Monodoc.Node matched_node, System.String url)
in <0x0011b> MonoDevelop.Gui.Pads.HelpTree:RowActivated (System.Object o, 
System.EventArgs e)
in (wrapper delegate-invoke) System.MulticastDelegate:
invoke_void_object_EventArgs (object,System.EventArgs)
in <0x00096> GLib.Signal:voidObjectCallback (IntPtr handle, IntPtr gch)
in (wrapper native-to-managed) GLib.Signal:voidObjectCallback (intptr,intptr)
in <0x00000> <unknown method>
in (wrapper managed-to-native) Gtk.Application:gtk_main ()
in <0x00007> Gtk.Application:Run ()
in <0x0048a> MonoDevelop.Commands.StartWorkbenchCommand:Run ()
in <0x00a7e> MonoDevelop.SharpDevelopMain:Main (System.String[] args)
------- Comment #1 From 2005-10-08 21:14:40 -------
Принято, в следующей сборке будет учтено. 
------- Comment #2 From 2005-10-09 12:03:48 -------
Это не monodevelop, а Gtk.HTML.
------- Comment #3 From 2005-11-02 20:31:42 -------
Зависимость должна быть с версией, ибо в Сизифе libgtkhtml-3.8.so.15, и GTK.
Html падает даже при установленном пакете.
Фактически, это блокер, ибо класс в текущем сизифе неюзабелен.
------- Comment #4 From 2006-10-14 11:56:06 -------

*** This bug has been marked as a duplicate of 7644 ***