Bug 820 - Broken dependencies
: Broken dependencies
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libgtk+2-devel)
: unstable
: all Linux
: P4 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-04-11 08:56 by
Modified: 2005-08-29 00:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-04-11 08:56:50
Отсутствуют зависимости на libpango-devel и libatk-devel.
---

---
Мне захотелось посмотреть на VDK/VDKBuilder (vdkbuilder.sourceforge.net).
Им надо glib/gtk+ >= 2.0.0.
Это у меня стоит:

# rpm -qa | grep glib2
glib2-2.0.1-alt1
glib2-devel-2.0.1-alt1

# rpm -qa | grep libgtk+2
libgtk+2-2.0.1-alt1
libgtk+2-devel-2.0.1-alt1

Соответственно, установлены libpango-1.0.1-alt1 и libatk-1.0.1-alt1.

Однако при сборке gtk+-2.0 не находится. Расследование показало:

# pkg-config --libs gtk+-2.0
Package pangox was not found in the pkg-config search path.
Perhaps you should add the directory containing `pangox.pc\'
to the PKG_CONFIG_PATH environment variable
Package \'pangox\', required by \'GDK\', not found

# rpm -ihv libpango-devel-1.0.1-alt1.i586.rpm

# pkg-config --libs gtk+-2.0
Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc\'
to the PKG_CONFIG_PATH environment variable
Package \'atk\', required by \'GTK+\', not found

# rpm -ihv libatk-devel-1.0.1-alt1.i586.rpm

# pkg-config --libs gtk+-2.0
-L/usr/X11R6/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm
-lpangox-1.0 -lpangoxft-1.0 -lXft -lXrender -lXext -lX11 -lfreetype -lpango-1.0
-lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
------- Comment #1 From 2004-05-24 14:58:29 -------
на мантейнера 
 
------- Comment #2 From 2004-05-24 14:58:39 -------
на мантейнера 
 
------- Comment #3 From 2004-05-24 15:12:28 -------
fixed