Bug 8215 - 1.5.0-alt1 не пересобирается с --disable'ами
: 1.5.0-alt1 не пересобирается с --disable'ами
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/gaim)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-10-14 12:59 by
Modified: 2006-05-11 10:48 (History)


Attachments
Исправление условной сборки (696 bytes, patch)
2005-10-14 13:06, Andrei Bulava
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-10-14 12:59:22
Не работает "условная сборка", т.е. сборка с --enable/--disable, которые
отличаются от значений, установленных в spec-файле.
Steps to Reproduce:
1. $ rpmbuild --rebuild --disable perl --disable tcl --disable gevolution
gaim-1.5.0-alt1.src.rpm

Actual Results:  
Двоичные пакет не собираются.

Expected Results:  
Двоичные пакет собираются.
------- Comment #1 From 2005-10-14 13:06:45 -------
Created an attachment (id=1181) [details]
Исправление условной сборки

Не с первой попытки довёл до ума, потому задержался с навешиванием бага.

Помешало ещё и то, что на текущем Сизифе gaim не пересобирается с --enable-nas.
Выяснил, что это из-за изменений в ... .pc-файлах gdk (
/usr/lib/pkgconfig/*gdk*.pc ). Надо править configure/makefile'ы, но на это у
меня  просто не хватило времени, поэтому я тестировал свой патч с
--disable-nas.
------- Comment #2 From 2005-12-08 16:50:01 -------
fixed in alt2

Ждите в сизифе