Bug 8223 - Depends on mktemp but does not require it
: Depends on mktemp but does not require it
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/alternatives)
: unstable
: all Linux
: P2 critical
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-10-15 02:43 by
Modified: 2005-10-20 14:21 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-10-15 02:43:04
Серьёзная проблема: если из basesystem убрать пакет dev, то базовая сборочная
среда разваливается, поскольку пакет alternatives не замкнут.

$ rpmquery -l alternatives |fgrep bin/ |xargs -r grep -w mktemp
/usr/bin/alternatives-update:    AVAIL=`mktemp -t $PROG.avail.XXXXXX`
/usr/bin/alternatives-update:    CHANGES=`mktemp -t $PROG.changes.XXXXXX`
/usr/bin/alternatives-update:    NEW=`mktemp -t $PROG.new.XXXXXX`
/usr/bin/alternatives-upgrade:    TEMPFILE=`mktemp -t $PROG.XXXXXX`
/usr/sbin/alternatives-update:    AVAIL=`mktemp -t $PROG.avail.XXXXXX`
/usr/sbin/alternatives-update:    CHANGES=`mktemp -t $PROG.changes.XXXXXX`

Необходимо добавить
Requires: mktemp >= 1:1.3.1

/usr/sbin/alternatives-update:    NEW=`mktemp -t $PROG.new.XXXXXX`
------- Comment #1 From 2005-10-20 14:21:09 -------
добавлено