Bug 828 - User with id=500 ignored
: User with id=500 ignored
Status: CLOSED DUPLICATE of bug 150
: Sisyphus
(All bugs in Sisyphus/fetchmail-daemon)
: unstable
: all Linux
: P4 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2002-04-12 12:06 by
Modified: 2009-05-10 09:31 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2002-04-12 12:06:42
--- /etc/rc.d/init.d/fetchmail.bak      Tue Mar 12 15:41:00 2002
+++ /etc/rc.d/init.d/fetchmail  Tue Mar 12 15:41:07 2002
@@ -16,7 +16,7 @@
 # Check that fetchmailrc exists.
 [ -x /usr/bin/fetchmail ] || exit
 
-NON_SYSTEM_USERS=`awk -F: \'{if ($3>500) print $1}\' </etc/passwd`
+NON_SYSTEM_USERS=`awk -F: \'{if ($3>=500) print $1}\' </etc/passwd`
 LOCKFILE=/var/lock/subsys/fetchmail
 RETVAL=0

---

---

------- Comment #1 From 2002-09-28 21:26:10 -------
Fetchmain startup script is buggy but this issue seems to be fixed.
------- Comment #2 From 2002-09-28 21:26:10 -------
Fetchmain startup script is buggy but this issue seems to be fixed.