Bug 8418 - Неправильная зависимость на mod_php и apache
: Неправильная зависимость на mod_php и apache
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/horde3)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-11-04 23:42 by
Modified: 2009-05-10 09:32 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-11-04 23:42:48
см. #8416. То же самое касается и всех horde3-* зависимых пакетов. Вообще
несколько странно - они должны требовать лишь то, что не требует horde3, а не
дублировать зависимости.
------- Comment #1 From 2005-11-05 00:02:06 -------
1) Вместо mod_php - требовать php-engine - понятно.
2) По поводу независимости от web-сервера.
Пока у нас всё в %apache_htdocsdir + конфиг только для apache.
Предлагается horde3 распилить в horde3 и horde3-env-{apache, ...}?
------- Comment #2 From 2005-11-05 03:34:45 -------
(In reply to comment #1)
> 2) По поводу независимости от web-сервера.
> Пока у нас всё в %apache_htdocsdir + конфиг только для apache.
> Предлагается horde3 распилить в horde3 и horde3-env-{apache, ...}?
можно просто horde3-htconf-{apache, ...}
------- Comment #3 From 2005-11-05 12:49:36 -------
> > Предлагается horde3 распилить в horde3 и horde3-env-{apache, ...}?
> можно просто horde3-htconf-{apache, ...}
Предложения, куда всё положить - принимаются.
/var/www лежит в apache-common
------- Comment #4 From 2005-11-05 19:14:43 -------
Не надо никуда бежать сломя голову, пока нет внятной web policy.
------- Comment #5 From 2005-11-05 22:05:28 -------
Тогда можно ограничиться заменой mod_php на php-engine, отрыванием лишних
зависимостей в horde3-*. Соотв. из apache будёт нужен только apache-common.
------- Comment #6 From 2005-11-29 00:42:56 -------
horde 3.0.7 и остальные обновленные пакеты ушли в /i/S/
------- Comment #7 From 2006-01-07 21:02:16 -------
спасибо.