Bug 8471 - проблемы с маршрутизацией при неполном конфигурировании при установке
: проблемы с маршрутизацией при неполном конфигурировании при установке
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/alterator-net-eth)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
: 7763
:
  Show dependency tree
 
Reported: 2005-11-11 16:05 by
Modified: 2010-04-19 11:27 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-11-11 16:05:20
Если при установке сконфигурировать только один интерфейс, во-первых, просто 
непонятно зачем стартует zcip (но это к инсталлеру скорее всего...) и 
конфигурит остальные, а во вторых таблица маршрутизации получается несколько 
странная в плане default gw: 

Kernel IP routing table 
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface 
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0 
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1 
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth2 
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth3 
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 eth3 
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 eth2 
0.0.0.0         0.0.0.0         0.0.0.0         U     0      0        0 eth1 
0.0.0.0         192.168.1.254   0.0.0.0         UG    0      0        0 eth0 

Ну и доступа за 192.168.1.0/24 нет, естественно.
------- Comment #1 From 2005-11-11 23:58:14 -------
Проблема воспроизводится каждый раз? Очень похоже на #4208 и #7763.
------- Comment #2 From 2005-11-12 09:33:51 -------
Да, что-то общее чувствуется. Про "каждый раз" не скажу - первый раз поставил 
с конфигурированием только одного интерфейса. Если время останется, попробую 
на этой же машинке еще раз на новый диск поставить, а пока ее надо к работе 
готовить. 
------- Comment #3 From 2005-11-12 10:20:45 -------
Я имею в виду "при каждой загрузке с одной и той же конфигурацией?"
------- Comment #4 From 2005-11-12 14:59:02 -------
К сожалению, постустановочня конфигурация уже изменена и zcip был удален. При 
установке zcip обратно и удалении eth2 и eth3 не воспроизводится. Так что 
проверю, если хватит времени на повторную установку. 
------- Comment #5 From 2005-11-17 17:52:14 -------
Проверил. Каждый раз. Причем сразу после установки все нормально, а вот после 
первой перезагрузки начинается. 
------- Comment #6 From 2005-11-17 18:35:18 -------
Аттачьте /etc/net архивом или шлите мне почтой.
------- Comment #7 From 2005-11-17 20:14:14 -------
Ok. Только я и эту машинку уже переделать успел (предыдущая вообще уже 
работает)... :-( Так что, до следующего раза, но будет достаточно скоро, думаю. 
------- Comment #8 From 2005-11-25 21:13:21 -------
(In reply to comment #6) 
 
> Аттачьте /etc/net архивом или шлите мне почтой. 
 
Уехало. Еще выяснилась подробность. Для воспроизведения эффекта с некоторыми 
платами необходимо, чтобы был вставлен сетевой кабель. Изначально я эффект 
увидел на интеловских гигабитных адаптерах, на стомегабитных интеловских без 
наличия кабеля у несконфигурированного адаптера не воспроизводится. 
 
 
------- Comment #9 From 2006-09-10 14:00:58 -------
Посмотрев свежим взглядом, я вижу, что по-другому получиться не могло. В
конфигурации по умочанию ALLOW_UNKNOWN=yes. Интерфейс unknown сконфигурирован
следующим образом:

BOOTPROTO=dhcp-ipv4ll
USE_HOTPLUG=on

Вот и имеем, что после загрузки сетевого модуля, который создаст сетевой
интерфейс, для которого не окажется конфигурации, по другому и не получится.
zcip подберёт адрес из autorange и навесит default route. Если не хотите такого
поведения, удалите пакет etcnet-defaults-desktop. Зачем такая конфигурация по
умолчанию, спрашивать нужно не меня.
Закрываю.
------- Comment #10 From 2006-09-11 11:24:59 -------
Только надо было не закрывать тогда уж, а перевесить...
сейчас попробую.
------- Comment #11 From 2006-09-11 12:28:32 -------
Можно перевесить на конфигуратор сети.
------- Comment #12 From 2006-09-16 22:28:55 -------
Стас, можно придумать более изящное решение?
------- Comment #13 From 2006-09-18 12:40:58 -------
Что нужно сделать изящнее?

Я не совсем понял сути проблемы. Сделай краткое описание проблемы пожайлуста -
сделаю всё что смогу для её решения.

------- Comment #14 From 2006-10-15 10:16:43 -------
Основной момент - появление нескольких default gw. Надо сделать так, чтобы 
zcip не создавал более одного маршрута по умолчанию.
------- Comment #15 From 2006-11-19 19:26:26 -------
Мне кажется, правильнее в установщике не конфигурировать более одного
интерфейса
для hotplug+IPv4LL. А если пользователь сам сконфигурировал хотя бы один
интерфейс, то и вообще не добавлять ничего к его выбору.
------- Comment #16 From 2009-10-15 16:53:39 -------
(In reply to comment #14)
> Основной момент - появление нескольких default gw. Надо сделать так, чтобы 
> zcip не создавал более одного маршрута по умолчанию.

Это https://bugzilla.altlinux.org/show_bug.cgi?id=7763 .
------- Comment #17 From 2010-04-19 11:27:52 -------
Нет  zcip - нет проблемы. :-)
( Bug 7763 )