Bug 8504 - x86_64 build
: x86_64 build
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/php-mysql)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
: relnote
:
:
  Show dependency tree
 
Reported: 2005-11-17 11:41 by
Modified: 2006-08-29 16:07 (History)


Attachments
Proposed patch (642 bytes, patch)
2005-11-17 11:42, Damir Shayhutdinov
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-11-17 11:41:32
Из-за плохой проверки в скрипте configure пакет не собирается на x86_64.
configure не находит mysql, потому что ищет его в /usr/lib, а он находится в
/usr/
lib64
------- Comment #1 From 2005-11-17 11:42:49 -------
Created an attachment (id=1246) [details]
Proposed patch

Прикладываю патч к спеку, с которым собирается.
------- Comment #2 From 2005-11-17 13:27:11 -------
Согласен. Сделаю как можно скорее.
------- Comment #3 From 2005-12-02 17:11:31 -------
исправлено
------- Comment #4 From 2006-02-16 01:16:14 -------
(In reply to comment #1)
> Прикладываю патч к спеку, с которым собирается.

-BuildRequires: gcc-c++ hostinfo libMySQL-devel zlib-devel
+BuildRequires: gcc-c++ hostinfo libMySQL-devel zlib-devel sed

sed в зависимости можно было не добавлять -- он доступен и так, потому что его
требуют основополагающие пакеты.