Bug 8544 - Need glib2 version dependency
: Need glib2 version dependency
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/planner)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-11-23 17:02 by
Modified: 2005-11-26 01:50 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-11-23 17:02:05
[gorev@demos gorev]$ rpm -q planner
planner-0.13-alt9
[gorev@demos gorev]$ rpm -q glib2
glib2-2.4.5-alt1
[gorev@demos gorev]$ planner

** (planner:4517): WARNING **:
/usr/lib/planner/storage-modules/libstorage-mrproject-1.so: undefined symbol:
g_assert_warning

(planner:4517): Planner-WARNING **: Невозможно открыть модуль просмотра
'/usr/lib/planner/libgantt-task.so: undefined symbol: g_assert_warning'


(planner:4517): Planner-WARNING **: Невозможно открыть модуль просмотра
'/usr/lib/planner/views/libresource-view.so: undefined symbol: g_assert_warning'


(planner:4517): Planner-WARNING **: Невозможно открыть модуль просмотра
'/usr/lib/planner/libgantt-task.so: undefined symbol: g_assert_warning'


(planner:4517): Planner-WARNING **: Невозможно открыть модуль просмотра
'/usr/lib/planner/libgantt-task.so: undefined symbol: g_assert_warning'


(planner:4517): Planner-WARNING **: Невозможно открыть файл модуля
'/usr/lib/planner/plugins/libhtml-plugin.so: undefined symbol: g_assert_warning'

[gorev@demos gorev]$ sudo apt-get install glib2
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие дополнительные пакеты будут установлены:
  libnatspec
Следующие пакеты будут ОБНОВЛЕНЫ:
  glib2
Следующие НОВЫЕ пакеты будут установлены:
  libnatspec
1 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 528 не будет
обновлено.
Необходимо получить 0B/596kB архивов.
После распаковки потребуется дополнительно 431kB дискового пространства.
Продолжить? [Y/n]
Совершаем изменения...
Preparing...                  
###################################################################################################
[100%]
1: libnatspec                 
###################################################################################################
[ 50%]
2: glib2                      
###################################################################################################
[100%]
Завершено.
[gorev@demos gorev]$ planner
[gorev@demos gorev]$ rpm -q glib2
glib2-2.6.5-alt1
------- Comment #1 From 2005-11-26 00:53:04 -------
исправил в planner-0.13-alt10  
------- Comment #2 From 2005-11-26 01:50:40 -------
Виноват поспешил "отрапортовать" :(   
На самом деле зависимость есть:   
 
[pv@localhost pv]$ apt-cache depends planner| grep glib2   
    glib2-2.8.3-alt1   
    glib2-2.8.3-alt1   
    glib2-2.8.3-alt1   
  
[pv@localhost pv]$ rpm -q planner 
planner-0.13-alt9 
 
 
Так что planner-0.13-alt10 отменяется...