Bug 8582 - error in specfile -- it is not x86_64 compliant.
: error in specfile -- it is not x86_64 compliant.
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/wxGTK2u)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-12-01 02:59 by
Modified: 2006-08-18 22:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-12-01 02:59:49
В спек-файле есть строчка %__ln_s -f ../lib/wx/config/`ls
%buildroot%_libdir/wx/config` %buildroot%_bindir/wx-config, которая, по понятным
причинам (../lib в x86_64 нет) делает симлинк wx-config нерабочим при установке
в x86_64-систему.

еще вызывает сомнения строчка %__subst 's/$(top_builddir)\/lib/\/usr\/lib/'
%buildroot%_datadir/wx/examples/src/makeprog.env
------- Comment #1 From 2005-12-13 12:07:53 -------
../lib всегда есть, это же в дереве исходников. а вот %_libdir, видимо, другой. 
поскольку у меня нет в наличии x86_64, исправить пока не могу.
------- Comment #2 From 2006-02-24 15:34:57 -------
1) могу потестировать на собираемость wxGTK2u
2) райдер готов был предоставлять сборочные x86_64 сервера

в любом случае это не совсем достойный ответ
------- Comment #3 From 2006-08-18 22:06:30 -------
давно исправлено, закрываю.