Bug 8596 - .desktop file generator handles paths with spaces incorrectly
: .desktop file generator handles paths with spaces incorrectly
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/wine)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-12-06 07:41 by
Modified: 2005-12-16 00:00 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-12-06 07:41:15
Nowadays wine intercepts certain WinAPI calls which should create shortcuts in
Windows Start Menu and Desktop. Wine then creates appropriate freedesktop.org
.desktop files (in ~/Desktop and ~/Desktop/WINE Applications.

Unfortunately sometimes these .desktop-files are generated not completely
correctly. The working path of the application (typically a path to the
application .exe-file) usually contains spaces within (e.g. because of "Program
Files") and thus must be quoted by application setup procedures (smth like
"C:\Program Files\2gis\Nsk"). But when this path is translated to Path entry of
the corresponding .desktop-file it should be unquoted back:

Path=$HOME/.wine/drive_c/Program Files/2gis/Nsk

Otherwise the setting doesn't have an effect which may break certain
applications (e.g. 2gis Nsk)
Steps to Reproduce:
1. You may try to install 2gis/Nsk (may be downloaded for free from
http://download.2gis.ru/arhives/2gisNsk87.exe to see the problem
------- Comment #1 From 2005-12-14 11:41:12 -------
Да, действительно. 
Будет исправлено в следующей сборке. 
------- Comment #2 From 2005-12-16 00:00:16 -------
fixed since 20051214-alt1