Bug 8602 - не хватает зависимостей на libnss,libnspr,libgal
: не хватает зависимостей на libnss,libnspr,libgal
Status: CLOSED WONTFIX
: Sisyphus
(All bugs in Sisyphus/evolution)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-12-06 11:12 by
Modified: 2006-09-12 10:13 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-12-06 11:13:00
не хватает зависимостей на libnspr и libnss
rpm -qR evolution  показывает зависимость на libssl3.so и libplc4.so, но эти
библиотеки есть в системе от других пакетов.
также не хватает зависимости на libgal


Steps to Reproduce:
1.apt-get install evolution
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  libgtkhtml3
The following NEW packages will be installed:
  evolution libgtkhtml3
0 upgraded, 2 newly installed, 0 removed and 0 not upgraded.
Need to get 11.8MB of archives.
After unpacking 31.7MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 ftp://ftp.altlinux.com i586/master libgtkhtml3 3.8.2-alt1 [864kB]
Get:2 ftp://ftp.altlinux.com i586/master evolution 2.4.2-alt1 [11.0MB]
Fetched 11.8MB in 55s (215kB/s)
Committing changes...
Preparing...                
############################################################### [100%]
1: libgtkhtml3              
############################################################### [ 50%]
2: evolution                
############################################################### [100%]
Done.

2. evolution
evolution: error while loading shared libraries: libplc4.so: cannot open shared
object file: No such file or directory
3. evolution
evolution: error while loading shared libraries: libssl3.so: cannot open shared
object file: No such file or directory
4. ldd /usr/bin/evolution
        linux-gate.so.1 =>  (0xffffe000)
        libeshell.so.0 => /usr/lib/evolution/2.4/libeshell.so.0 (0xb7fed000)
        libetimezonedialog.so.0 =>
/usr/lib/evolution/2.4/libetimezonedialog.so.0 (0xb7fe8000)
        libemiscwidgets.so.0 => /usr/lib/evolution/2.4/libemiscwidgets.so.0
(0xb7f89000)
        libeutil.so.0 => /usr/lib/evolution/2.4/libeutil.so.0 (0xb7f51000)
        libecal-1.2.so.3 => /usr/lib/libecal-1.2.so.3 (0xb7ea3000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb7e20000)
        libgnomecanvas-2.so.0 => /usr/lib/libgnomecanvas-2.so.0 (0xb7df6000)
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb7cdf000)
        libz.so.1 => /lib/libz.so.1 (0xb7ccc000)
        libm.so.6 => /lib/libm.so.6 (0xb7ca9000)
        libgconf-2.so.4 => /usr/lib/libgconf-2.so.4 (0xb7c77000)
        libgnome-2.so.0 => /usr/lib/libgnome-2.so.0 (0xb7c63000)
        libpopt.so.0 => /lib/libpopt.so.0 (0xb7c5c000)
        libgnomeui-2.so.0 => /usr/lib/libgnomeui-2.so.0 (0xb7bcf000)
        libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0xb7bc6000)
        libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0xb7baf000)
        libbonoboui-2.so.0 => /usr/lib/libbonoboui-2.so.0 (0xb7b50000)
        libglade-2.0.so.0 => /usr/lib/libglade-2.0.so.0 (0xb7b38000)
        libgnomevfs-2.so.0 => /usr/lib/libgnomevfs-2.so.0 (0xb7ad8000)
        libgtkhtml-3.8.so.15 => /usr/lib/libgtkhtml-3.8.so.15 (0xb7a34000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb79e1000)
        libc.so.6 => /lib/libc.so.6 (0xb78c8000)
        libedataserverui-1.2.so.6 => /usr/lib/libedataserverui-1.2.so.6 (0xb78a6000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb786d000)
        libbonobo-2.so.0 => /usr/lib/libbonobo-2.so.0 (0xb7814000)
        libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xb7519000)
        libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xb74e1000)
        libORBit-2.so.0 => /usr/lib/libORBit-2.so.0 (0xb748e000)
        libbonobo-activation.so.4 => /usr/lib/libbonobo-activation.so.4 (0xb747a000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xb7464000)
        libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xb73e4000)
        libetable.so.0 => /usr/lib/evolution/2.4/libetable.so.0 (0xb7371000)
        libetext.so.0 => /usr/lib/evolution/2.4/libetext.so.0 (0xb7356000)
        libevolution-widgets-a11y.so.0 =>
/usr/lib/evolution/2.4/libevolution-widgets-a11y.so.0 (0xb734e000)
        libevolution-a11y.so.0 => /usr/lib/evolution/2.4/libevolution-a11y.so.0
(0xb733a000)
        libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb7336000)
        libgnomeprintui-2-2.so.0 => /usr/lib/libgnomeprintui-2-2.so.0 (0xb72fc000)
        libedataserver-1.2.so.4 => /usr/lib/libedataserver-1.2.so.4 (0xb7232000)
        libdl.so.2 => /lib/libdl.so.2 (0xb722e000)
        libplc4.so => not found
        libplds4.so => not found
        libnspr4.so => not found
        libart_lgpl_2.so.2 => /usr/lib/libart_lgpl_2.so.2 (0xb7217000)
        libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xb71f2000)
        /lib/ld-linux.so.2 (0x80000000)
        libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xb71ef000)
        libesd.so.0 => /usr/lib/libesd.so.0 (0xb71e7000)
        libaudiofile.so.0 => /usr/lib/libaudiofile.so.0 (0xb71c2000)
        libgnome-keyring.so.0 => /usr/lib/libgnome-keyring.so.0 (0xb71b6000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0xb7197000)
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0xb70ca000)
        libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xb70b0000)
        libssl.so.4 => /lib/libssl.so.4 (0xb707f000)
        libcrypto.so.4 => /lib/libcrypto.so.4 (0xb6f7d000)
        libhowl.so.0 => /usr/lib/libhowl.so.0 (0xb6e56000)
        libresolv.so.2 => /lib/libresolv.so.2 (0xb6e43000)
        librt.so.1 => /lib/librt.so.1 (0xb6e30000)
        libgailutil.so.17 => /usr/lib/libgailutil.so.17 (0xb6e29000)
        libebook-1.2.so.5 => /usr/lib/libebook-1.2.so.5 (0xb6df9000)
        libORBitCosNaming-2.so.0 => /usr/lib/libORBitCosNaming-2.so.0 (0xb6df4000)
        libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xb6ded000)
        libcairo.so.2 => /usr/lib/libcairo.so.2 (0xb6d9a000)
        libXrandr.so.2 => /usr/X11R6/lib/libXrandr.so.2 (0xb6d96000)
        libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0xb6d8e000)
        libXinerama.so.1 => /usr/X11R6/lib/libXinerama.so.1 (0xb6d8a000)
        libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0xb6d7c000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb6d4d000)
        libXcursor.so.1 => /usr/X11R6/lib/libXcursor.so.1 (0xb6d44000)
        libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0xb6d3b000)
        libXfixes.so.3 => /usr/X11R6/lib/libXfixes.so.3 (0xb6d36000)
        libgnomeprint-2-2.so.0 => /usr/lib/libgnomeprint-2-2.so.0 (0xb6ccf000)
        libplc4.so => not found
        libplds4.so => not found
        libnspr4.so => not found
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6c61000)
        libcamel-1.2.so.0 => /usr/lib/libcamel-1.2.so.0 (0xb6c17000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb6bf3000)
        libglitz.so.1 => /usr/lib/libglitz.so.1 (0xb6bce000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0xb6bae000)
        libkrb5.so.3 => /lib/libkrb5.so.3 (0xb6b3a000)
        libk5crypto.so.3 => /lib/libk5crypto.so.3 (0xb6b17000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0xb6b14000)
        libgssapi_krb5.so.2 => /lib/libgssapi_krb5.so.2 (0xb6afc000)
        libplc4.so => not found
        libplds4.so => not found
        libnspr4.so => not found
        libssl3.so => not found
        libsmime3.so => not found
        libnss3.so => not found
        libsoftokn3.so => not found
        libkrb5support.so.0 => /lib/libkrb5support.so.0 (0xb6af7000)
------- Comment #1 From 2006-09-11 19:01:29 -------
наверно уже все нормально
------- Comment #2 From 2006-09-12 10:13:20 -------
(In reply to comment #1)
> наверно уже все нормально

Да, уже не актуально.