Bug 8662 - libfontenc.so.1: cannot open shared object file
: libfontenc.so.1: cannot open shared object file
Status: CLOSED WORKSFORME
: Sisyphus
(All bugs in Sisyphus/xorg-x11)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2005-12-16 13:01 by
Modified: 2007-02-21 15:25 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-12-16 13:01:52
...
fonts-bitmap-misc            
##################################################
/usr/X11R6/bin/mkfontscale: error while loading shared libraries: 
libfontenc.so.1: cannot open shared object file: No such file or directory
...

[root@titan root]# apt-cache search libfontenc
xorg-x11-libs - Shared libraries needed by the X Window System version 11 
release 6
[root@titan root]# apt-get install xorg-x11-libs
Reading Package Lists... Done
Building Dependency Tree... Done
xorg-x11-libs is already the newest version.
0 upgraded, 0 newly installed, 0 removed and 0 not upgraded.
[root@titan root]# whereis libfontenc.so.1
libfontenc.so:
[root@titan root]# whereis libfontenc.so
libfontenc:
Steps to Reproduce:
1. Make CDROM disk image by mklivecd

Actual Results:  
fonts-bitmap-misc            
##################################################
/usr/X11R6/bin/mkfontscale: error while loading shared libraries: 
libfontenc.so.1: cannot open shared object file: No such file or directory

Expected Results:  
No error message
------- Comment #1 From 2005-12-16 13:36:20 -------
это не ко мне  
------- Comment #2 From 2005-12-16 13:39:37 -------
мантейнеру separator 
------- Comment #3 From 2005-12-16 14:08:02 -------
(In reply to comment #2)
> мантейнеру separator 
Тебе виднее
Я считаю что проблема не в Separator
а именно при установке пакета fonts-bitmap-misc
------- Comment #4 From 2005-12-19 13:17:31 -------
Неверно. Проблема не имеет отношения к separator. 

Необходимо в пакете fonts-bitmap-misc в post-скриптах добавить проверку
DURING_INSTALL и написать /etc/firsttime.d/ скрипт, который будет дублировать
функциональность post-install скриптов. 

Такая же ошибка будет вылезать при установке этого пакета инсталятором.

Кстати, пакета fonts-bitmap-misc не наблюдается в bugzilla :-(
------- Comment #5 From 2006-01-02 23:03:41 -------
как 7.0 приедет - будет 
------- Comment #6 From 2007-02-21 15:01:37 -------
оно вообще сейчас воспроизводится?
------- Comment #7 From 2007-02-21 15:17:44 -------
По идее не должно - spt ведёт себя по другому.
------- Comment #8 From 2007-02-21 15:25:19 -------
значит закрываем