Bug 8752 - [solution] librcc+libdb4 = wrong perms and other troubles
: [solution] librcc+libdb4 = wrong perms and other troubles
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/librcc)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
: 10428
  Show dependency tree
 
Reported: 2005-12-28 23:23 by
Modified: 2012-03-16 13:58 (History)


Attachments
Suren Chilingaryan's patch for librcc/libdb4 problem (4.10 KB, patch)
2006-12-17 23:45, Michael Shigorin
no flags Details | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-12-28 23:23:52
Эта библиотека имеет возможность кэширования в Berkeley DB. Но каталоги
$HOME/.rcc/ и $HOME/.rcc/<DBNAME>.db/ создаются с правами 644 (функция
rccInitDb4) и последующие попытки обращения к этому каталогу завершаются
неудачей.
------- Comment #1 From 2006-01-06 22:27:42 -------
в новой версии пофикшено, после Рождества соберу
------- Comment #2 From 2006-12-17 23:45:58 -------
Created an attachment (id=1722) [details]
Suren Chilingaryan's patch for librcc/libdb4 problem

Рождество приближается, между прочим.  И тут ещё патчик, это насчёт "помогло rm
-rf ~/.rcc".
------- Comment #3 From 2006-12-17 23:48:02 -------
reassign
------- Comment #4 From 2006-12-18 00:05:42 -------
i586-alt-linux-gcc -pipe -Wall -O2 -march=i586 -mtune=pentium4 -Wall
-Wpointer-arith -o 
rccexternal rccexternal.o rcclibtranslate.o rccdb4.o  -lglib-2.0 -ldb
rccdb4.o: In function `rccDb4CreateContext':
rccdb4.c:(.text+0x34e): undefined reference to `rccLock'
rccdb4.c:(.text+0x3cd): undefined reference to `rccUnLock'
collect2: ld returned 1 exit status
make[2]: *** [rccexternal] Error 1
------- Comment #5 From 2006-12-18 09:42:20 -------
патч подправлен и добавлен в alt3
------- Comment #6 From 2006-12-19 19:53:54 -------
oops :[] а я тут работаетвотинетрожу. сорри
------- Comment #7 From 2007-03-07 11:48:39 -------
*** Bug 10918 has been marked as a duplicate of this bug. ***