Bug 8829 - Проблема с provides
: Проблема с provides
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/mailman)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-01-12 00:17 by
Modified: 2006-11-24 05:48 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-01-12 00:17:38
Думаю, что это бага: 
[lav@lav python]$ apt-cache whatdepends mailman  
mailman-4:2.1.6-alt2  
  trac-0.9-alt1  
    Требует: <python2.4(email)>  
      python-modules-email-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  python-modules-2.4.2-alt1.1  
    Требует: <python2.4(email)>  
      python-modules-email-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  python-module-twisted-1.3.0-alt1.1  
    Требует: <python2.4(email)>  
      python-modules-email-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  python-module-flup-0.5-alt0.svn1823  
    Требует: <python2.4(email)>  
      python-modules-email-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  python-module-bitten-0.5-alt1  
    Требует: <python2.4(email)>  
      python-modules-email-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  getmail-4.4.3-alt1  
    Требует: <python2.4(email)>  
      python-modules-email-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  eric-3.8.0-alt1  
    Требует: <python2.4(email)>  
      python-modules-email-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  python-tools-webchecker-2.4.2-alt1.1  
    Требует: <python2.4(Queue)>  
      python-modules-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  python-tools-idle-2.4.2-alt1.1  
    Требует: <python2.4(Queue)>  
      python-modules-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  python-module-cherrypy-2.1.0-alt1  
    Требует: <python2.4(Queue)>  
      python-modules-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  pybookreader-0.4.11-alt0.2  
    Требует: <python2.4(Queue)>  
      python-modules-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  nicotine-1.0.8-alt2  
    Требует: <python2.4(Queue)>  
      python-modules-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2  
  gajim-0.9-alt0.pre2  
    Требует: <python2.4(Queue)>  
      python-modules-2.4.2-alt1.1  
      mailman-4:2.1.6-alt2
------- Comment #1 From 2006-01-18 11:08:39 -------
[11:11:30] <migor> Привет, я не совсем понял в чем именно бага в зависимостях 
mailman? 
[11:18:59] <Lav> Я подозреваю что mailman предоставляет что-то лишнее типа 
python2.4(i18n), из-за чего вытягивается в ненужных случаях. 
------- Comment #2 From 2006-04-03 10:08:50 -------
Думаю это не моя бага. В пакете есть явная зависимость только на python. Все
остальное дописывает rpmbuild при сборке пакета.
------- Comment #3 From 2006-04-03 23:52:21 -------
Я не о зависимостях, я о provides. 
Посмотрите на  
rpm --provides mailman 
Не берусь судить кому нужны provides типа 
python2.4(Mailman.TopicMgr) 
, но 
python2.4(email) 
python2.4(i18n) 
откровенно вредны, потому что предоставляют то же, что и системные пакеты 
------- Comment #4 From 2006-04-04 13:41:24 -------
Provides я тоже явно не указываю. Есть идеи как подавить такое поведение
rpmbuild?
------- Comment #5 From 2006-04-04 23:24:02 -------
Думаю подойдёт  
AutoProv: yes, nopython  
------- Comment #6 From 2006-04-05 10:43:52 -------
Спасибо, это помогло :-)
пофиксено в пакете 2.1.7-alt3