Bug 8855 - bdist_altrpm.py is misplaced
: bdist_altrpm.py is misplaced
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/rpm-build-python)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-01-17 00:31 by
Modified: 2006-07-02 19:49 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-01-17 00:31:35
$ rpmquery -f /usr/lib/pythonunknown/distutils/command/bdist_altrpm.py
rpm-build-python-0.27-alt1
------- Comment #1 From 2006-01-17 10:59:36 -------
Вот блин... видел же!!!
------- Comment #2 From 2006-01-18 17:07:20 -------
*** Bug 7998 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2006-03-14 17:15:10 -------
Решение "в лоб":
BuildRequires: python = %__python_version
При этом в хэшер втянется python использованной при сборке SRPM версии.

rpmbuild -bs --with python2.4 rpm-build-python.spec у меня почему-то не
работает, собирается всё равно с 2.3.
------- Comment #4 From 2006-06-10 15:18:39 -------
Ну и чего?

$ python setup.py bdist_altrpm
[...]
error: invalid command 'bdist_altrpm'
$ sudo ln -s /usr/lib/pythonunknown/distutils/command/bdist_altrpm.py /usr/lib/
python2.4/distutils/command/bdist_altrpm.py
$ python setup.py bdist_altrpm
running bdist_altrpm
[...]
$ sudo rm -f /usr/lib/python2.4/distutils/command/bdist_altrpm.py

Так и живем.
------- Comment #5 From 2006-06-10 16:11:51 -------
fixed in 0.28-alt1