Bug 8956 - после обновления до 0.8.1-alt1 не запускается сеть с dhcp
: после обновления до 0.8.1-alt1 не запускается сеть с dhcp
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/etcnet)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-01-28 12:03 by
Modified: 2006-08-29 13:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-01-28 12:03:26
thresh@snowflake ~ $ sudo service network restartwith office
Computing interface groups: ..... 5 interfaces found
Stopping group 4/deplog (2 interfaces)
        Stopping ppp0: OK
        Stopping ppp1: OK
Processing /etc/net/vlantab: empty.
Stopping group 1/realphys (2 interfaces)
        Stopping eth0: ..OK
        Stopping eth1: ..OK
Stopping group 0/virtual (1 interfaces)
        Stopping lo: .OK
Computing interface groups: ..... 5 interfaces found
Starting group 0/virtual (1 interfaces)
        Starting lo: ....OK
Starting group 1/realphys (2 interfaces)
        Starting eth0: ....OK
        Starting eth1: ....RTNETLINK answers: Network is unreachable
.OK
Processing /etc/net/vlantab: empty.
Starting group 4/deplog (2 interfaces)
        Starting ppp0:  on boot SKIPPED
        Starting ppp1:  on boot SKIPPED
thresh@snowflake ~ $ sudo ip ro
thresh@snowflake ~ $ sudo ip ad
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
10: eth0: <BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:12:f0:12:34:ea brd ff:ff:ff:ff:ff:ff
24: eth1: <BROADCAST,MULTICAST,NOTRAILERS,UP> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether 00:0a:e4:30:98:d5 brd ff:ff:ff:ff:ff:ff
thresh@snowflake ~ $

конфигурация интерфейса eth1, на который должен получаться dhcp:
root@snowflake net/ifaces/eth1 # pwd
/etc/net/ifaces/eth1
root@snowflake net/ifaces/eth1 # ls
ipv4route#office  options#home  options#office
root@snowflake net/ifaces/eth1 # cat options\#office
USE_HOTPLUG=no
BOOTPROTO=dhcp
root@snowflake net/ifaces/eth1 # cat options\#home
USE_HOTPLUG=no
BOOTPROTO=static
root@snowflake net/ifaces/eth1 # cat ipv4route\#office
default via 172.16.127.1
root@snowflake net/ifaces/eth1 #

после вбивания руками адресов, ровно как и service network restartwith home,
"сеть" появляется.
------- Comment #1 From 2006-01-28 19:45:30 -------
точнее сказать, окончательно перестало работать :)
http://mid.gmane.org/drfvi9$51j$1@sea.gmane.org
------- Comment #2 From 2006-01-28 19:49:37 -------
Ещё есть такая мысль -- при restart где-то перед dhcpcd снимать текущий адрес с
интерфейса, может помочь в случаях, когда перешли из одной сети в другую
ноутбуком (или на dhcpd сменился диапазон раздаваемых адресов с запретом
старого
-- тоже наступил недавно).

Сейчас сперва оттаймаутится по попытке получить старый адрес, потом получит
новый.
------- Comment #3 From 2006-02-14 19:04:54 -------
Это решает проблему?
http://etcnet.org/files/etcnet-0.8.2-alt0.test1.noarch.rpm
------- Comment #4 From 2006-02-16 16:13:07 -------
(In reply to comment #3)
> Это решает проблему?
> http://etcnet.org/files/etcnet-0.8.2-alt0.test1.noarch.rpm

Нет, все ровно так же, как и в описании баги.
------- Comment #5 From 2006-02-20 15:32:55 -------
Шлите почтой архив с /etc/net, буду смотреть.
------- Comment #6 From 2006-03-07 13:59:03 -------
заработало с вот таким вот:

thresh@snowflake net/ifaces/eth1 $ cat options
USE_HOTPLUG=no
BOOTPROTO=static
MODULE=e100

thresh@snowflake net/ifaces/eth1 $ cat options\#office
TYPE=eth
LINKDETECT=yes
BOOTPROTO=dhcp
DHCP_ARGS=-R
------- Comment #7 From 2006-03-08 13:06:39 -------
А ifplugd тут ни при чём, часом? (включается ли он где, кроме options, и есть
ли
в процессах)
------- Comment #8 From 2006-08-18 22:05:05 -------
УМВР, закроем?
------- Comment #9 From 2006-08-24 20:58:42 -------
Я не против закрыть.
------- Comment #10 From 2006-08-27 11:47:04 -------
Если (что маловероятно) эта ошибка ещё есть в последней версии, переоткройте
пожалуйста.