Bug 9034 - kernel 2.6.14 {vs26,std26}-smp cant find SCSI device LSI Logic on IBM eserver xSeries 335
: kernel 2.6.14 {vs26,std26}-smp cant find SCSI device LSI Logic on IBM eserver...
Status: CLOSED DUPLICATE of bug 8672
: Sisyphus
(All bugs in Sisyphus/kernel-image-std26-smp)
: unstable
: all Linux
: P1 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-02-07 17:19 by
Modified: 2006-09-17 11:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-02-07 17:19:37
При загрузке не находит SCSI устройства. Оборудование  
IBM @Server xSeries 335 (Type 8676) Контроллер LSI Logic. 

В версии ядра 2.6.12 все работает нормально.   

Steps to Reproduce:
1.Update kernel to newest in Sisyphus(2.6.14-smp) 
2. 
3. 
Actual Results:  
Can't find root filesystem 

Expected Results:  
Crush system
------- Comment #1 From 2006-02-07 17:26:36 -------
Reassigned to maintainer.
------- Comment #2 From 2006-02-07 17:43:37 -------
Пожалуйста, покажите вывод команды pciscan -v с 2.6.12 (от root).
------- Comment #3 From 2006-02-07 17:55:42 -------
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169610
------- Comment #4 From 2006-02-07 18:05:34 -------
(In reply to comment #3)
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169610

Я тоже это подозреваю; у нас уже висит bug #8672 по этому поводу.  Точно можно
будет сказать после получения информации об аппаратуре (pciscan).
------- Comment #5 From 2006-02-10 12:47:57 -------
(In reply to comment #0) 
Recommended driver     Description 
------------------     ----------- 
sworks-agp             Broadcom CMIC-LE Host Bridge (GC-LE chipset) [Host 
bridge] 
                       1166:0014  drivers: 15:sworks-agp  class:006:00:00 
                       slot: 0000:00:00.0  hwid: B7E3B99C5AA54909 
 
sworks-agp             Broadcom CMIC-LE Host Bridge (GC-LE chipset) [Host 
bridge] 
                       1166:0014  drivers: 15:sworks-agp  class:006:00:00 
                       slot: 0000:00:00.1  hwid: B7E3B99C5AA54909 
 
sworks-agp             Broadcom CMIC-LE Host Bridge (GC-LE chipset) [Host 
bridge] 
                       1166:0014  drivers: 15:sworks-agp  class:006:00:00 
                       slot: 0000:00:00.2  hwid: B7E3B99C5AA54909 
 
unknown                ATI Technologies Inc Rage XL [VGA compatible 
controller] 
                       1002:4752:1014:0240  drivers:  not found  
class:003:00:00 
                       slot: 0000:00:01.0  hwid: 96165FD9072F23A1 
 
i2c-piix4              Broadcom CSB5 South Bridge [Host bridge] 
                       1166:0201:1166:0201  drivers: 15:sworks-agp 
24:i2c-piix4 scb2_flash  class:006:00:00 
                       slot: 0000:00:0f.0  hwid: 3F03A4093F3E3647 
 
serverworks            Broadcom CSB5 IDE Controller [IDE interface storage 
controller] 
                       1166:0212:1166:0212  drivers: 24:serverworks 
serverworks  class:001:01:8a 
                       slot: 0000:00:0f.1  hwid: 040FABBBCEEA8D2B 
 
ohci-hcd               Broadcom OSB4/CSB5 OHCI USB Controller [OHCI USB 
Controller] 
                       1166:0220:1166:0220  drivers: 2.6|ohci-hcd 2.4|usb-ohci 
7:ohci-hcd usb-ohci  class:00c:03:10 
                       slot: 0000:00:0f.2  hwid: E3BA54F4ABFB37C3 
 
unknown                Broadcom CSB5 LPC bridge [ISA bridge] 
                       1166:0225:1166:0230  drivers:  not found  
class:006:01:00 
                       slot: 0000:00:0f.3  hwid: 7D0462CABFCDDBA5 
 
sworks-agp             Broadcom CIOB-X2 PCI-X I/O Bridge [Host bridge] 
                       1166:0101  drivers: 15:sworks-agp  class:006:00:00 
                       slot: 0000:00:11.0  hwid: 7A7F0BBFE220ED5C 
 
sworks-agp             Broadcom CIOB-X2 PCI-X I/O Bridge [Host bridge] 
                       1166:0101  drivers: 15:sworks-agp  class:006:00:00 
                       slot: 0000:00:11.2  hwid: 7A7F0BBFE220ED5C 
 
mptscsih               LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual 
Ultra320 SCSI [SCSI storage controller] 
                       1000:0030:1014:026d  drivers: 24:mptbase mptscsih  
class:001:00:00 
                       slot: 0000:01:01.0  hwid: 3425CF5F4D61069D 
 
tg3                    Broadcom Corporation NetXtreme BCM5703X Gigabit 
Ethernet [Ethernet controller] 
                       14e4:16a7:1014:026f  drivers: 24:tg3 tg3  
class:002:00:00 
                       slot: 0000:02:01.0  hwid: A0F23302D9180E4B 
 
tg3                    Broadcom Corporation NetXtreme BCM5703X Gigabit 
Ethernet [Ethernet controller] 
                       14e4:16a7:1014:026f  drivers: 24:tg3 tg3  
class:002:00:00 
                       slot: 0000:02:02.0  hwid: A0F23302D9180E4B 
 
e1000                  Intel Corporation 82545GM Gigabit Ethernet Controller 
[Ethernet controller] 
                       8086:1026:8086:1001  drivers: 24:e1000  class:002:00:00 
                       slot: 0000:02:03.0  hwid: 2132B41374D55F28 
 
 
------- Comment #6 From 2006-02-10 14:08:57 -------
Для адаптера с PCI ID 1000:0030 в 2.6.14 нужен модуль mptspi, который из-за
неверной информации в hwdatabase не попадает в initrd автоматически.

Пока что можно перейти на ручное управление - дописать в /etc/modules.conf
строку:

probeall scsi_hostadapter mptspi mptscsih

(mptscsih тут нужен, чтобы работало и на 2.6.12, где модуля mptspi нет).

Далее нужно перегенерировать initrd:

mkinitrd -fv /boot/initrd-2.6.14-std26-smp-alt5.img 2.6.14-std26-smp-alt5

Затем необходимо запустить lilo, если используется этот загрузчик (для grub
дополнительные действия не нужны).

*** This bug has been marked as a duplicate of 8672 ***