Bug 9076 - /usr/lib/libcupsimage.so.2 must be linked with -lcups
: /usr/lib/libcupsimage.so.2 must be linked with -lcups
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libcups)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-02-15 11:02 by
Modified: 2006-09-17 11:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-02-15 11:02:03
wrar@wrars-comp ~ $ ldd -r /usr/lib/libcupsimage.so.2
undefined symbol: cupsTempFd    (/usr/lib/libcupsimage.so.2)



Actual Results:  



Expected Results:
------- Comment #1 From 2006-02-15 12:20:32 -------
ну вообще говоря вовсе не обязательно. Правила линковки определяют авторы ...
возможно они в новых версиях что-то поменяли, а у нас ещё старый CUPS. Если это
мешает сборке какой-то программы просто добавьте там в makefile 
-lcups -lcupsimage.
------- Comment #2 From 2006-03-09 00:41:50 -------
С --as-needed не поможет.
С rpm-build-4.0.4-alt62 тоже не поможет.
Надо /usr/lib/libcupsimage.so.2 фиксить.
Мало ли чего там авторы недопонимают.
------- Comment #3 From 2006-08-21 17:16:50 -------
as-needed уже заставил-таки это исправить ;)