Bug 9094 - Добавить provides для x86_64
: Добавить provides для x86_64
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libjpeg-devel)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-02-17 10:34 by
Modified: 2006-02-17 18:53 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-02-17 10:34:20
Просьба приложить такой патч:
--- libjpeg.spec.orig   2005-05-11 02:44:52 +0400
+++ libjpeg.spec        2006-02-20 06:46:56 +0300
@@ -29,11 +29,17 @@
 Summary: Development tools for programs which will use the libjpeg library
 Group: Development/C
 Requires: %name = %serial:%version-%release
+%ifarch x86_64
+Provides %name-mmx-devel
+%endif
 
 %package devel-static
 Summary: Static libjpeg library
 Group: Development/C
 Requires: %name-devel = %serial:%version-%release
+%ifarch x86_64
+Provides %name-mmx-devel-static
+%endif
 
 %package utils
 Summary: Programs for manipulating JPEG format image files
------- Comment #1 From 2006-02-17 10:34:37 -------
Готов сделать NMU ;)
------- Comment #2 From 2006-02-17 17:38:21 -------
А почему не
%ifnarch %ix86
?

------- Comment #3 From 2006-02-17 17:41:52 -------
да, ifnarch будет правильнее.. выложишь исправленный ?
------- Comment #4 From 2006-02-17 17:46:03 -------
Выложу.  Что-нибудь пересобрать с новым пакетом под x86_64?
------- Comment #5 From 2006-02-17 17:50:32 -------
libquicktime и всё что от него зависит (там прилично).

Но главное конечно libquicktime
------- Comment #6 From 2006-02-17 17:51:33 -------
да, сейчас если просто пересобрать Sisyphus - соберётся не просто много, а
просто очень много новых пакетов.

Там kdelibs всё-таки запинали в x86_64, а от kdelibs зависит много всего.
------- Comment #7 From 2006-02-17 18:53:51 -------
Добавил provides в -alt6.