Bug 9284 - Non working fsck / with LVM2/EVMS on /
: Non working fsck / with LVM2/EVMS on /
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/startup)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-03-20 12:14 by
Modified: 2006-03-23 12:17 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-03-20 12:14:22
При попытке загрузить систему с / на LVM2/EVMS fsck / выполняется раньше, чем
это возможно, поэтому загрузка прерывается
Steps to Reproduce:
Был Компакт, обновленный до почти последнего Сизифа (1-2-недельной 
давности). С помощью cpio он был перенесен на RAID1/LVM2. Разделы 
распределены так:

/dev/md0          /boot
/dev/system/root  /
/dev/system/home  /home
/dev/system/var   /var

system - это имя группы томов, размещенной на /dev/md2
Actual Results:  
Загрузить ядро и использовать /dev/system/root в качестве / мне удалось. При
загрузке уже на этапе отработки стартовых скриптов я получаю:

fsck.ext3: No such device or address while trying to open /dev/system/root
Possibly non existent or swap device?

Ну и дальше / монтируется в ro и мне предлагают войти в систему в 
однопользовательском режиме.

Сильно похоже на то, что fsck.ext3 вызывается слишком рано, т.е. надо 
пересматривать инитскрипты. fsck.ext3 у меня прошел удачно только после 
того, как я, залогинившись в однопользовательском режиме:

1) вручную перемонтировал / в rw (т.к. утилиты lvm любят писать в /var) 
2) запустил сервис udevd
3) создал необходимые устройства с помощью vgscan --mkdev (последнее 
обязательно)
4) обратно перемонтировал / в ro.


Expected Results:  
И как теперь правильно это разрулить?
------- Comment #1 From 2006-03-23 12:17:38 -------
Прошу прощения за невнимательность, но выяснилось, что все гораздо проще:
вместо
изменения порядка запуска скриптов достаточно, чтобы до запуска udevd в /dev/
присутствовали все lvm-устройства