Bug 9348 - требуется обновление до версии 5.0.19 (MySQL Bug #15719)
: требуется обновление до версии 5.0.19 (MySQL Bug #15719)
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libMySQL)
: unstable
: all Linux
: P2 normal
Assigned To:
:
: http://bugs.mysql.com/bug.php?id=15719
:
:
:
  Show dependency tree
 
Reported: 2006-03-31 14:06 by
Modified: 2006-04-10 15:50 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-03-31 14:06:34
По URL - описание проблемы и её решение в виде
http://lists.mysql.com/commits/1607

Т.е., если есть сомнения в возможности срочно обновиться до MySQL-5.0.19, прошу
срочно наложить вышеупомянутый патч.

На грабли наступил случайно, от "умного" решения разработчиков MySQL изменить
умолчание на значение MYSQL->reconnect с 1 на 0, начиная с версии MySQL-5.0.3
(см. комментарии к http://dev.mysql.com/doc/refman/5.0/en/mysql-ping.html ).

Слинкованные с libmysqlclient.so.15 jabberd2-c2s и jabberd2-sm рассчитывают
восстановить утраченное по таймауту соединение с БД именно с помощью вызова
mysql_ping(), и вызов mysql_options( &mysql, MYSQL_OPT_RECONNECT, ... ) _до_
mysql_real_connect() (как описано в документации) это не вылечил из-за MySQL
Bug
#15719

Я теперь вообще теряюсь, как мне исправить jabberd2 наименьшей кровью, чтоб
люди
не напоролись на труднопостижимые баги при эксплуатации jabberd2 с libMySQL
версий >= 5.0.3 и < 5.0.18... Хоть вставляй в configure проверку на проблемные
версии библиотеки (и то, как я при этом распознаю патченный на предмет MySQL
Bug
#15719 libMySQL-5.0.18?), а в спек Requires: %{get_dep libMySQL}, помимо
приложения патча с вызовом mysql_options().

Как правильно поступить?
------- Comment #1 From 2006-04-10 12:29:15 -------
Указанный патч приложен в MySQL-5.0.18-alt2.
------- Comment #2 From 2006-04-10 15:50:29 -------
Спасибо!