Bug 9352 - ldd -u говорит неправду
: ldd -u говорит неправду
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/glibc-utils)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-03-31 17:35 by
Modified: 2006-09-15 01:50 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-03-31 17:35:10
$ ldd -u /usr/bin/xcpufreq 
Unused direct dependencies:
        /usr/lib64/libhw.so.0
        /lib64/libgcc_s.so.1
        /lib64/libc.so.6
        /usr/lib64/libstdc++.so.6

выглядит как-то подозрительно.

пакет libhw-tools
------- Comment #1 From 2006-03-31 17:45:45 -------
$ ldd -u /bin/ls
Unused direct dependencies:
        /lib/librt.so.1
        /lib/libtinfo.so.5

Короче говоря, не работает ldd -u.
------- Comment #2 From 2006-05-01 15:24:52 -------
На $(rpm -qf =ldd), а то так не найти.

Кстати, ldd -u -r работает (вроде бы) правильно.
------- Comment #3 From 2006-05-01 15:35:38 -------
$ env -i LD_DEBUG=unused LD_TRACE_LOADED_OBJECTS=1 LD_BIND_NOW=1
/lib/ld-linux.so.2 /bin/ls 
$ env -i LD_DEBUG=unused LD_TRACE_LOADED_OBJECTS=1 /lib/ld-linux.so.2 /bin/ls 
Unused direct dependencies:
        /lib/librt.so.1
        /lib/libtinfo.so.5

Так что действительно достаточно пропатчить скрипт.
------- Comment #4 From 2006-05-01 15:51:12 -------
(In reply to comment #3)
> Так что действительно достаточно пропатчить скрипт.
Какой скрипт, и на предмет чего?


------- Comment #5 From 2006-05-01 16:05:02 -------
Скрипт elf/ldd.bash.in на тему bind_now=yes в режиме --unused.
------- Comment #6 From 2006-05-16 21:24:02 -------
Fixed in 2.3.6-alt5.