Bug 9358 - У libpolypaudio-devel нет зависимости на libpolypaudio
: У libpolypaudio-devel нет зависимости на libpolypaudio
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/polypaudio)
: unstable
: all Linux
: P2 major
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-04-03 14:03 by
Modified: 2006-04-29 17:07 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-04-03 14:03:17
libpolypaudio-devel не имеет зависимости на libpolypaudio, что приводит к битым 
ссылкам при установке libpolypaudio-devel и необходимости "костылей" при сборке 
пакетов, использующих libpolypaudio (приходится в зависимости сборки кроме 
libpolypaudio-devel указывать ещё и libpolypaudio, buildreq таких случаев не 
отслеживает)
------- Comment #1 From 2006-04-03 14:29:27 -------
Понял. Попровлю в следующей сборке.
------- Comment #2 From 2006-04-14 13:47:54 -------
скоро выйдет 0.8 тогда и починю.
------- Comment #3 From 2006-04-20 18:36:59 -------
0.8 версия сегодня вышла. так что, скоро починю.
------- Comment #4 From 2006-04-20 22:57:53 -------
(In reply to comment #0)
> libpolypaudio-devel не имеет зависимости на libpolypaudio
"И эти люди..." ;-)
------- Comment #5 From 2006-04-21 13:22:46 -------
(In reply to comment #4)
> (In reply to comment #0)
> > libpolypaudio-devel не имеет зависимости на libpolypaudio
> "И эти люди..." ;-)

Чья бы корова мычала. ;)
------- Comment #6 From 2006-04-22 13:41:04 -------
fixed in 0.8-alt1
------- Comment #7 From 2006-04-25 15:12:28 -------
(In reply to comment #6)

В 0.8 сильно изменилось API. Нельзя ли параллельно собрать libpolypaudio0.7?

------- Comment #8 From 2006-04-25 15:30:09 -------
(In reply to comment #7)
> (In reply to comment #6)
> 
> В 0.8 сильно изменилось API. Нельзя ли параллельно собрать libpolypaudio0.7?
> 
> 

Зачем? Кто-то сильно хочет именно 0.7?

На сколько мне известно, что программы (и патчи для различных тулзей) которые
используют polypaudio написаны одним человеком. И он обещал в течении 2 недель
обновить всё что использует polypaudio до нового API.

Кстати, libao-polyp, gstreamer-polyp и всё остальное тоже будет в Сизифе. Я упакую.
------- Comment #9 From 2006-04-25 15:33:01 -------
(In reply to comment #8)
> На сколько мне известно, что программы (и патчи для различных тулзей) которые
> используют polypaudio написаны одним человеком. И он обещал в течении 2 
недель
> обновить всё что использует polypaudio до нового API.

Ок, ждём две недели:)
------- Comment #10 From 2006-04-25 15:46:42 -------
(In reply to comment #7)
> (In reply to comment #6)
> 
> В 0.8 сильно изменилось API. Нельзя ли параллельно собрать libpolypaudio0.7?
> 
> 

Это ты ради какого приложения хотел? Просто интересно...
------- Comment #11 From 2006-04-25 15:48:02 -------
Блин, пошли в аську или джаббер... А то устраивать чат в глюкозавре
неинтересно...

74999682 / icesik jabber ru