Bug 9448 - libxml2-devel should require zlib-devel
: libxml2-devel should require zlib-devel
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/libxml2-devel)
: unstable
: all Linux
: P2 minor
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-04-22 18:12 by
Modified: 2006-08-10 23:35 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-04-22 18:12:53
Люди жалуются, что -lz в libxml-2.0.pc есть, а зависимости нет:
http://community.livejournal.com/ru_linux/625946.html
------- Comment #1 From 2006-04-22 19:53:38 -------
Будет исправлено в следующем релизе.
Если это создает реальные проблемы, дайте знать.
------- Comment #2 From 2006-04-23 04:03:37 -------
Может лучше убрать -lz из libxml-2.0.pc?
------- Comment #3 From 2006-04-23 11:00:31 -------
Можно и так.
Я думаю, это непринципиальная проблема, если клиенты своевременно делают buildreq.
------- Comment #4 From 2006-04-29 19:08:23 -------
Да, -lz и -lm лучше убрать.
libxml2-devel-static мы всё равно не пакуем.
------- Comment #5 From 2006-06-04 16:21:23 -------
(In reply to comment #1)
> Будет исправлено в следующем релизе.

OK, в одном релизе не получилось, буду делать -alt2.
------- Comment #6 From 2006-06-08 11:58:29 -------
Fixed in 2.6.26-alt1