Bug 9492 - Свен виснет при использывании OSD и запуске VMWare
: Свен виснет при использывании OSD и запуске VMWare
Status: CLOSED FIXED
: Sisyphus
(All bugs in Sisyphus/sven)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-04-29 17:00 by
Modified: 2007-08-23 08:27 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-04-29 17:00:33
Если в настройках Sven'а выбрана опция View XOSD=enable, то после запуска
какой-нибудь виртуальной машины в VMWare он виснет. Снять его можно по SIGQUIT,
SIGTERM.
Бага довольно давняя... Затруднений работы других приложений, использующих
xosd,
не наблюдается.

Версии используемых программ:
$ rpm -qa |egrep "sven|libxosd|^vmware"
vmware-5.5.0-alt1
libxosd-2.2.12-alt2
sven-0.4.2-alt0

Steps to Reproduce:
1. Запускаем Sven с включенным OSD.
2. Запускаем VMWare
3. Стартуем виртуальную машину
4. Переключаемся в неё
5. Переключаемся в основную систему
6. Жмём какую-нибудь мультимедийную кнопку, или изменяем громкость - чтобы sven
попытался наOSDить чего-нибудь на экране
Actual Results:  
Получаем зависшего Sven'а
------- Comment #1 From 2006-04-30 16:56:06 -------
Очевидно, это лучше сразу в апстрим.  А вообще там xosd чинили/заменяли IIRC,
можете попробовать собрать текущую версию со sven.linux.kiev.ua.
------- Comment #2 From 2006-05-01 02:53:25 -------
(In reply to comment #1)
Попробовал. Какая-то у них там очень экспериментальная версия, у меня ни
малейшего xosd в ней вообще не появилось, хотя, возможно, я ей не догадался
инклюдесов каких подсунуть. Ну да все равно она странная - вместо того, чтобы
учиться кодам мультимедийных клавиш, она исполняет их функции. Причем, кажется,
не только своих - от попыток манипулированья громкостью (опять же,
безрезультатных), компьютер заснул богатырским сном - сработала hibernate,
посаженная на совсем другую кнопку.
Прочем, речь не о том. Это я к тому, что все равно у них версия нерабочая.
------- Comment #3 From 2007-02-20 19:45:57 -------
Не должно воспроизводиться с версией 0.6-alt1 (возможности проверить в
настоящий
момент не имеется.)
------- Comment #4 From 2007-06-01 13:40:38 -------
Актуально?
------- Comment #5 From 2007-06-02 13:09:00 -------
> Актуально?

Насчёт невозможности проверки с моей стороны - да. Насчёт наличия проблемы - не
должно. Модуль OSD был переписан полностью.
------- Comment #6 From 2007-08-23 08:27:49 -------
Вследствие длительного отсутствия сообщений о воспроизводимости, баг считается
исправленным. Если у кого-то всё-таки воспроизводится - переоткрывайте.