Bug 9530 - Не компилируется под ALC30
: Не компилируется под ALC30
Status: CLOSED NOTABUG
: Sisyphus
(All bugs in Sisyphus/x264)
: unstable
: all Linux
: P2 normal
Assigned To:
:
:
:
:
:
  Show dependency tree
 
Reported: 2006-05-07 07:34 by
Modified: 2006-05-23 19:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-05-07 07:34:32
Посоветовали тут багу добавить:
x264 не компилируется под ALC30, не может найти X11.so:

gcc -shared -o libx264.so.46.......
/usr/bin/ld: cannot find -lX11

(из BuildRequires выкинуты X11-devel и добавлены xorg-x11-devel и xorg-x11-libs)
Помогло принудительное добавление в x264-svn-20060426-shared.patch в строку 
+ $(CC) -shared -o $@ $(OBJS) $(OBJASM) -lX11 -lm -lpthread -Wl,-soname,$(SONAME)
параметра -L/usr/X11R6/lib
------- Comment #1 From 2006-05-10 15:26:04 -------
(In reply to comment #0)
> Посоветовали тут багу добавить:
> x264 не компилируется под ALC30, не может найти X11.so:

Странно, почему багрепорт на компонент "ALT Linux Sisyphus"? В Sisyphus-то 
компилируется. Сорри, но меня нет возможности тестировать бэкпорты к ALC30. Мне 
кажется это не то место для данного багрепорта.
В любом случае - по бэкпортам лучше писать в соотв. рассылку/багзиллу или мне 
лично - я с удовольсьвием включу ваши решения в сборку, если они не ломают 
собираемость в Sisyphus.

Попробуйте пересобрать x264-0.0-alt20060510 или выше, есть большая вероятность, 
что он соберётся.
------- Comment #2 From 2006-05-10 15:55:08 -------
Описанная ошибка в данной ветке (ALT Linux Sisyphus) не воспроизводится.
------- Comment #3 From 2006-05-23 19:47:45 -------
fixed